Dell E6430 comparibility

Hi all,
I have an older Dell Laptop Latitude 6430 and would like to use it and make a full install of Manjaro XFCE. I downloaded the latest version and tested the live version (with an usb-stick) however after startup, GUI, connection with wifi (succeeds) and starting the browser my system hangs. Caps Lock light blinks, no mouse, no keyboard. I had to stop the system manually. The system has an I5 processor, 8GB memory and 400GB HD (ssd) and currently works just fine with Kubuntu 20.10 but I’m in favor of trying the latest so I’d like to use Manjaro. Are there problems with this Dell laptop or should I just install on hardware?
thank you for some insight.

Hello and welcome,

There should be no issue, if is this same model as described here

Just the detail about the drivers for the dGPU. Worth checking that. Instead of using the AUR, just boot with the proprietary driver option.

For the record, my 2011 Latitude 6520 works fine with dual boot Manjaro KDE / Manjaro Cinnamon.

Just for verification, you need to make sure the BIOS is setup for UEFI boot only and not with Legacy support.
If two USB drives show up for booting, make sure it is the UEFI version you are booting into.

I personally have not found any Dell Laptop that does not support Linux in the last 8 years…

My E6440 has no issues at all

Indeed this is a legacy setup, so I did use the legacy boot but after reading your post I tried the UEFI usb (bios is in legacy mode, but who knows) and it gives exactly the same result: after connecting to wifi (and that requires mouse movements and keyboard input) you start the browser and then the system completely hangs, no ctrl-alt-F3, no mouse, no keyboard. The only thing that works is the power button. I tried this with the free video driver and also the nonfree. The problem is of course that it freezes on the live usb and there are no traces left after a reboot.

Addition: I had some time and tried again, now forcing UEFI by the settings in BIOS. And now I’m writing thia from the newly installed Manjaro on my Dell. Thanks to the people that replied and sorry for taking your time: my problem is solved.

My system has no fingerprint sensor, however it is nearly the one on the arch wiki.

jdc@jdc-Latitude-E6430:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:648b Microdia Integrated Webcam
Bus 001 Device 003: ID 413c:8197 Dell Computer Corp. BCM20702A0 Bluetooth Module
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
jdc@jdc-Latitude-E6430:~$ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 36 bits physical, 48 bits virtual
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 2
Core(s) per socket: 2
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 58
Model name: Intel® Core™ i5-3340M CPU @ 2.70GHz
Stepping: 9
CPU MHz: 1352.728
CPU max MHz: 3400,0000
CPU min MHz: 1200,0000
BogoMIPS: 5382.04
Virtualization: VT-x
L1d cache: 64 KiB
L1i cache: 64 KiB
L2 cache: 512 KiB
L3 cache: 3 MiB
NUMA node0 CPU(s): 0-3
Vulnerability Itlb multihit: KVM: Mitigation: VMX disabled
Vulnerability L1tf: Mitigation; PTE Inversion; VMX conditional cache flushes, SMT vulnerable
Vulnerability Mds: Mitigation; Clear CPU buffers; SMT vulnerable
Vulnerability Meltdown: Mitigation; PTI
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Full generic retpoline, IBPB conditional, IBRS_FW, STIBP conditional, RSB filling
Vulnerability Srbds: Vulnerable: No microcode
Vulnerability Tsx async abort: Not affected
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall n
x rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor
ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm
cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln p
ts md_clear flush_l1d

I hope this comes out well, as I failed to find a preview of this post

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.