Deleted something

I rebooted my system and landed here:

I was deleting some things earlier and probably touched something i wasn’t supposed to. What should i do?

try logging with your standard user and enter sudo systemctl restart gdm.service

I don’t remember my username exactly. Is there a command to list the users?

login as root and cat /etc/passwd. you will find your username somewhere below.

Thanks i am now logged in as my regular user. I think i know what the problem is, i deleted pulseaudio (with all dependencies) while trying to remove an equalizer program. I tried now to install it with pacman and reboot but it didn’t work. Tried also to restart gdm.service but it returned Unit gdm.service not found.

Now that your login works take a look what you have removed before and install it again.

grep remove /var/log/pacman.log

… shows you the packages you removed. So you know which packages you have to install again. :grinning:

1 Like

11:26 is when i deleted pulseaudio. So i have to install all there packages again? Please tell me these is a shortcut.

Seems you also removed your gnome. :laughing:

I would start with this:

pamac install gnome-meta

The only ‘shortcut’ is to restore from a backup or reinstall the whole system. If you dont want to reinstall or you dont have a backup of your system you have to install all these packages again by your own. :neutral_face:

I restored the system with Timeshift, luckily i had a snapshot from last week. Thank you all for the fast and insightful support and long live Timeshift!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.