Deleted KDE Partition Manager. How do I get it back?

Hi all,

I ran into some trouble with the default KDE Partition manager 3 when I tried to set mount points. I tried to update it to the KDE Partition manager 4 from the package manager but after the update it didn't launch at all.

I then rebooted my pc and found that the KDE Partition manager 4 wasn't installed at all. Don't know what happened there. So then I just ended up doing everything I wanted through the terminal but I am still left with no GUI. I installed gparted in the mean time but would rather use the KDE Partition manager as you can edit mount points with it. How do I get it back?

Thank you a hundred times over for taking your time and reading my issue!

Try reinstalling it with pamac install partitionmanager

If it still isn't showing up in your menu try running kbuildsycoca5

2 Likes

Thanks for such a quick answer. After pamac install partitionmanager, my terminal got stuck here

** (pamac:4223): CRITICAL **: 15:28:08.531: transaction_interface_daemon.vala:42: failed to connect to dbus daemon: Error calling StartServiceByName for org.manjaro.pamac.daemon: Unit -.mount is masked.


** (pamac:4223): CRITICAL **: 15:28:08.918: pamac_daemon_start_trans_run: assertion 'self != NULL' failed
^C

Ctrl+c doesn't help :confused:

Can we see the output of systemctl list-unit-files --state=masked

0 unit files listed.

First make sure you are using a good mirror and that your system is fully up-to-date

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

If the update installs any packages, reboot.

Then try installing using pacman.

sudo pacman -S partitionmanager

After doing that it installed partitionmanager-4.0.0-1 , the same package I had before. I appreciate the help so far. Tbh this isn't a major issue but if you have the time to find a solution I'll gladly have it :smiley:

did you make sure you removed 3 first, then install 4?

No, I think I installed 4 without uninstalling 3.

Try running it from a terminal and see if it shows any errors there.

You don't need to do that.

you're not actually updating so it's a good idea to remove the old version, especially since it's list right there on the software manager when you search for the new version. Aguirre not necessary but still believe a good practice.

I ran partitionmanager with and without sudo. This was the result

partitionmanager: error while loading shared libraries: libkpmcore.so.8: cannot open shared object file: No such file or directory

OK, parttion manager uses kpmcore, both packages have to be installed.
But first you need to remove partitionmanager3 and kpmcore3 packages as these will conflict.

sudo pacman -R partitionmanager3 kpmcore3

then reinstall:

 sudo pacman -S partitionmanager kpmcore

If it still doesn't work then do the same in reverse.

However, pacman should warn about the conflict and ask to remove the already installed conflicting package.

2 Likes

which is EXACTLY what i said, remove 3 first then install 4.

1 Like

Yes, I saw that, but I figured that maybe it just did not compute, so I gave the exact commands. :wink:

If I remember correctly, the ONLY reason for there to even be a partitionmanager3 and kpmcore3 in the repositories, was because of Calamares requiring the older kpmcore version 3. And since we ship the KDE ISO with partitionmanager pre-installed, partitionmanager3 was then also needed.

1 Like

Interesting reading, I've updated my systems too now after reading this thread. I have some external storage (both USB3.1 and NAS) I repurpose occasionally so need Partition Manager. Build 3 of course works okay but I may as well have the latest to avoid deprecation issues in the future.

Calamares devs possibly need a nudge to update the kpmcore dependency :thinking:

you can of course achieve the same in pamac GUI. Select the partitionmanager3 and kpmcore3 packages for removal and then select partitionmanager4 to install. pamac checks the dependencies and draws in the right kpmcore version and smart tools as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by