Default terminal change not working

Want konsole and gnome-terminal. Want gnome-terminal for default. When I change it in the gui, it just ignores me.

Desktop is kde or gnome ?
how to run this terminal ? shortcut ?.. icon … by file browser …

KDE. Terminal is executed with ‘gnome-terminal’. Icon? By file browser? What are you on about? I don’t want it so it is default app when I execute a specific file type or something; I want it to be system default for everything like my IDE default application to use, processes that I setup to run in a terminal at boot, etc.

System Settings → Personalization → Applications → Default Applications → Terminal Emulator

Already tried that originally. When I said gui in my original post, that is what I was referring to. It doesn’t work.

give an example of what you do

I click on terminal emulator and select Terminal. Doesn’t do it as default is still opening konsole. Tried UXTerm as well but that doesn’t work either.

Have tried logging out and back in?

tried shutdown and nothing