Default Option when clicking / opening a Folder

When I click my home folder on my desktop or click any option in the Places menu then Musicbranz Picard is launched, rather than nautilus.

If I’m IN nautilus then I can select folders fine.

It seems to me like something’s got confused where the default action to respond to a folder has switched from nautilus to picard.

Where is this defined so I can change it?

Dropbox > Open Dropbox Folder does the same

Open a terminal window an run this command:

xdg-mime default org.gnome.Nautilus.desktop inode/directory

Alternatively, you can set the option in the ~/.config/mimeapps.list file (in the [Default Applications] section):

inode/directory=org.gnome.Nautilus.desktop
1 Like

Exactly what I was after - thanks! I think it bust as my home still has cruft on it from when I was trialing nemo months ago - nemo isn’t in my build since I switched my distro.

I am slowly merging my old config data and the default profile config data to get my Manjaro install working properly but without losing any of my previous stuff.

1 Like

My issue recurred later after installing Visual Studio code with just the first command. I’m now editing the file directly and making sure that Nautilus is the first option in that list. Hopefully it’ll `stick’ now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.