Deepin Terminal, menu is opened far away from the terminal window

Deepin terminal menu is opened far away from the terminal window shown as in following figure. If the terminal window is on the right side of the screen, then the menu becomes invisible.

Is there any way I can fix it?

Here is my inxi:

System:    Host: ideapad720s Kernel: 4.19.36-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Deepin 15.10 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81BD v: Lenovo ideapad 720S-14IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: 6LCN23WW(V1.09) date: 11/12/2018 
Battery:   ID-1: BAT1 charge: 41.8 Wh condition: 49.5/55.0 Wh (90%) model: LG PABAS0241231 status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 3c:00.0 
           Display: x11 server: X.Org 1.20.4 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.19.36-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lenovo driver: ath10k_pci v: kernel 
           port: 4040 bus ID: 3a:00.0 
           IF: wlp58s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4 
Drives:    Local Storage: total: 476.94 GiB used: 53.73 GiB (11.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000L2 size: 476.94 GiB 
Partition: ID-1: / size: 104.51 GiB used: 8.70 GiB (8.3%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 211 Uptime: 37m Memory: 15.54 GiB used: 1.36 GiB (8.7%) Init: systemd Compilers: gcc: 8.3.0 Shell: bash 
           v: 5.0.3 inxi: 3.0.33 

Looks like your NVidia drivers aren't set up right. I recommend installing the nonfree (closed source) NVidia drivers and using this tutorial to enable them. Then reboot and try again.

Note: the "Using nvidia" section of the wiki linked above is the one to follow.

Thanks for your reply.

I previously installed OS with free driver option, and in this way computer freezes after booting. Then I used non-free driver option and it turns out good and gives a functional machine with following GPU driver installed:

I think bumblebee is actually using free driver for integrated gpu and dGPU is not involved. And to be honest, I prefer to continue using the integrated gpu for better battery life as the machine is a laptop.

Do you have any advice for this? I am somehow lost in configuring this Nvidia Optimus thing with two GPUs. I cannot totally disable dGPU in BIOS as it is dual booting with windows I do some gaming on it.

Are you connecting an external gpu to a laptop? If so, I suggest you stick with the bumblebee driver because I think that would have the best support for switching between when you have the external gpu connected and when you don't. If you want better gaming performance with the straight up nvidia driver you'll have to switch it to that when you have the external gpu connected but this will probably cause issues if you boot the machine without the external gpu connected. Therefore you should stick with the bumblebee driver.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.