Deepin DELL workstation heavily reduced max brightness after some of recent updates

One of my machines after update from clean manjaro-deepin-18.0.2-stable-x86_64.iso to latest version i have a problem - my maximum brightness reduced heavily (looks like at least by 1/3).

This could be potentially a lot of things like:

  • Deepin bug
  • Nvidia bug
  • Kernel / mesa / some stuff i'm not aware of...?

inxi -Fxxz

System:    Host: x133-pc Kernel: 5.1.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Deepin 15.10.1 tk: Qt 5.12.4 
           wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Precision 7730 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0VC5H3 v: A00 serial: <filter> UEFI: Dell v: 1.6.0 date: 12/25/2018 
Battery:   ID-1: BAT0 charge: 93.5 Wh condition: 94.1/97.0 Wh (97%) volts: 12.0/11.4 model: BYD DELL GW0K986 serial: <filter> 
           status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i9-8950HK bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 69720 
           Speed: 800 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 801 
           9: 800 10: 800 11: 799 12: 800 
Graphics:  Device-1: NVIDIA GP104GLM [Quadro P5200 Mobile] vendor: Dell driver: nvidia v: 430.26 bus ID: 01:00.0 
           chip ID: 10de:1bb5 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: Quadro P5200/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k5.1.15-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15bb 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus ID: 6f:00.0 chip ID: 8086:2526 
           IF: wlp111s0 state: up mac: <filter> 
Drives:    Local Storage: total: 267.35 GiB used: 11.59 GiB (4.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
           ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
Partition: ID-1: / size: 109.49 GiB used: 11.48 GiB (10.5%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 34 C 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 265 Uptime: N/A Memory: 62.75 GiB used: 782.4 MiB (1.2%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.7 running in: deepin-terminal inxi: 3.0.34 

Any help is very welcome, for now i can't even get the cause of problem. :bug:

P.S. My other machines doesn't have this effect under same circumstances btw :upside_down_face:

Just to give your some completely unrelated information Deepin 15.11 will be released around July 10

Yeah i know (probably they'll mess it even worse than 15.10 this time :laughing:), i just not even sure it's specifically Deepin's problem i got...

Looks to me like more of a system / driver level problem, but i don't know how or what to do exactly to test it further and exclude other options...

Hi @keybreak
Have you tried I different kernel? (rule out the kernel at least)

Hey @ant, nice to see you here :slight_smile:

Well...When i was doing the clean test yesterday:

  1. At first i was on 4.19 LTS (which is default on this .iso and everything was fine).
  2. Then i've updated system - issue become apparent.
  3. Then i've updated to 5.1.15-1 Kernel, which changed nothing in that sense

So Kernels itself we can pretty much rule out i guess (not sure about maybe some settings / parameters independent of Kernel itself, which could probably change)

I wasn't really on this machine too much lately, but as far as i know this issue have come with 1-2 Manjaro system updates before...

This is a laptop, do you get the same on your desktop, assuming you have it installed.

Nope, my desktop with nvidia is fine, and also i don't have same with other laptop (intel video card).
It happened specifically on this machine

Oh and before you ask - it's straight up nvidia proprietary driver, no hybrid / optimus crap :upside_down_face:
So should pretty much behave as desktop driver...Theoretically speaking

Could it be the backlight of that dell, maybe an update pertinent to that laptop messed with it somehow.

Rarely used arch on a laptop, so I have no clue what to look for!?

yeah I spotted that :wink:

I don't know, one thing is for sure max-brightness have become very limited, and it's OS level, since:

  1. Bios is super bright
  2. .iso itself before update is again super bright

Anyone knows how to set maximum brightness independent of DE, through terminal (to rule out Deepin)?

May help!?

https://wiki.archlinux.org/index.php/Backlight
https://wiki.archlinux.org/index.php/Backlight#NVIDIA_settings

1 Like

Thx, now that's superb. :upside_down_face:

cat /sys/class/backlight/nvidia_0/max_brightnes
100

cat /sys/class/backlight/nvidia_0/brightnes
42

While both nvidia and Deepin settings set to max :laughing:
I'll try to change through udev rule now to test if it works...


Anyone have ideas why it happens this way?
Basically after some updates system started to think that max_brightness is 42, but what exactly could cause such behavior?

Yep, manually setting /sys/class/backlight/nvidia_0/brightnes do work as expected, it's really full brightness now.

Even after changing brightness with keys and through brightness in Deepin's settings.

But once you reboot - it's still 42, so...

Questions still holds, what's going on / why update messed up this value / what should one do to fix it properly? :slight_smile:

related?
https://bugs.freedesktop.org/show_bug.cgi?id=110407

1 Like

you can try a couple common parameters for dell.
acpi_backlight=vendor
acpi_rev_override=1

1 Like

@masterfix
Hmm...Perhaps somehow it's connected since nouveau must use some kind of similar stuff to nvidia proprietary.

Although i use proprietary nvidia and have slightly different video card

@dglt
Nope, i've tried both of those separately and simultaneously - it's same, after reboot brightness gets bumped to 42

But as far as i understood in the past - those are useful for button controls problems, not the initial brightness "clamp"

Some other thoughts...

Have you tried on Battery only / Power only
Have a look through dconf-editor and search for 'brightness' see if anything amiss...

AC / BAT behaves same

dconf-editor also looks like yours, nothing unusual sticks out

if your able to change the brightness manually, you could just change the function key's keybinding. light seems to work better than xbacklight (which does not work for me). setting brightness via xrandr doesnt change display brightness but instead increases/decreases gamma so thats no good either.

but light works perfectly.

sudo pacman -S light
#assign these to vol function keybinds
light -U 10    #decreases backlight 10%
light -A 10    #increases backlight 10%

Well...I suppose more adequate solution than would be to just write bash script which writes 100 to:
/sys/class/backlight/nvidia_0/brightnes and execute it on each boot, coz buttons are fine...

But anyway it's all duct-tape solution for something that worked just few months ago :crazy_face:

Do you guys solid that it's nvidia driver causing this on each boot after those updates, and not something Manjaro / Deepin specific?

I should write to nvidia dev forum then, they work slow on solving stuff, but...They do work


setting brightness via xrandr doesnt change display brightness but instead increases/decreases gamma

Wait, really?
That's insane, i should remember this! :smiley:

sounds like a perfect fit for deepin.

"Deepin, It's all duct tape!" , they could even get the flex-tape guy for advertising. :laughing::speedboat:

2 Likes