Deepin Clone app does not open

deepin

#1

I’m running the latest up to date version of Manjaro Deepin (system info says I’m running distribution 18.0.0) and I want to use and try and test out an app called Deepin Clone (back up tool), which I downloaded from pamac (v 7.3.0-5). When I open it, it asks me for my password, I enter it, then nothing happens and nothing opens.

Any ideas why the app doesn’t start up or fails to properly launch? Thanks for any help!


#2

can you start the app once in the terminal?
Then you might get an error message


#3

I don’t know if I did it right (maybe you can tell me the correct way if I’m wrong), but I ran the command sudo deepin-clone in the terminal and this was the output that it gave me: first command I ran sudo deepin-clone and second command I ran just deepin-clone, both had different errors. Any thoughts?

sudo deepin-clone
[2018-11-22, 05:18:30.823] [Warning] [=>: 0] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[2018-11-22, 05:18:30.848] [Debug  ] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::setSingleInstanceByDbus: 203] register service failed: QDBusError("org.freedesktop.DBus.Error.Disconnected", "Not connected to D-Bus server")
[2018-11-22, 05:18:30.849] [Error  ] [main.cpp=>main: 143] As well as the process is running
deepin-clone
[2018-11-22, 07:17:51.951] [Warning] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 280] "dtkwidget2" can not find qm files
<FileAppender::append> Cannot open the log file /tmp/.deepin-clone.log
[2018-11-22, 07:17:51.951] [Warning] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 280] "deepin-clone" can not find qm files
<FileAppender::append> Cannot open the log file /tmp/.deepin-clone.log
[2018-11-22, 07:17:51.951] [Error  ] [main.cpp=>main: 149] Load translator failed
<FileAppender::append> Cannot open the log file /tmp/.deepin-clone.log
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 07:17:51.954] [Info   ] [main.cpp=>main: 213] Application command line: deepin-clone
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 07:17:51.964] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 288] current state: "", new state: "SelectAction"
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 07:17:51.964] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 292] action: "Backup", mode: "Disk"
source: ""
target: ""

#4

The app. ask for password, in terminal

mint@deepin Linux 4.19.2-1-MANJARO x86_64 18.0.0 Illyria
→ ~ deepin-clone
[2018-11-22, 11:41:39.847] [Debug  ] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 270] translatePath after feedback: "/usr/share/dtkwidget/translations/dtkwidget2_de"
<FileAppender::append> Cannot open the log file /tmp/.deepin-clone.log
[2018-11-22, 11:41:39.847] [Debug  ] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 270] translatePath after feedback: "/usr/share/deepin-clone/translations/deepin-clone_de"
<FileAppender::append> Cannot open the log file /tmp/.deepin-clone.log
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 11:41:39.849] [Info   ] [main.cpp=>main: 213] Application command line: deepin-clone
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 11:41:39.862] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 288] current state: "", new state: "SelectAction"
<FileAppender::append> Cannot open the log file /var/log/deepin-clone.log
[2018-11-22, 11:41:39.862] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 292] action: "Backup", mode: "Disk"
source: ""
target: ""

it work/start whithout .

Edit: I use timeshift :wink: never deepin-clone. And I use unstable manjaro deepin.

With sudo

→ ~ sudo deepin-clone
[sudo] Passwort für mint: 
[2018-11-22, 11:54:59.911] [Warning] [=>: 0] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[2018-11-22, 11:54:59.923] [Debug  ] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 270] translatePath after feedback: "/usr/share/dtkwidget/translations/dtkwidget2_de"
[2018-11-22, 11:54:59.923] [Debug  ] [dapplication.cpp=>Dtk::Widget::DApplicationPrivate::loadTranslator: 270] translatePath after feedback: "/usr/share/deepin-clone/translations/deepin-clone_de"
[2018-11-22, 11:54:59.925] [Info   ] [main.cpp=>main: 213] Application command line: deepin-clone
[2018-11-22, 11:54:59.933] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 288] current state: "", new state: "SelectAction"
[2018-11-22, 11:54:59.933] [Info   ] [mainwindow.cpp=>MainWindow::setStatus: 292] action: "Backup", mode: "Disk"
source: ""
target: ""
→ ~ deepin-clone -v              
deepin-clone 1.0.0

#5

I’m having similar errors. See my edited second post with the error outputs.


#6

You have a Error Message, mine work. Sudo is needed.

XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’

Post output

printenv | grep RUNTIME

Ignore that warning, it’s normal when you run Qt applications as root in the user’s session.


Translation error
you need missing translation in path???

 "/usr/share/dtkwidget/translations/dtkwidget2_de"
"/usr/share/deepin-clone/translations/deepin-clone_de"

#7

how or where can I file a bug report for this?


#8

i just tried deepin-clone works for me
so its not package problem


#9

Maybe your locale not correct.
Bug report on github.com
@oberon know the place :wink:


#10

yes always use en us locale
cause en in locale for me never work
lutris wont launch with en in
many apps wont launch


#11

I’m using en us in my locale settings though.


#12

Same problem, I can’t get it to open on Manjaro KDE.

Output when running in terminal as root:

[2018-11-29, 21:00:30.501] [Warning] [=&gt;: 0] QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[2018-11-29, 21:00:30.507] [Debug &#160;] [dapplication.cpp=&gt;Dtk::Widget::DApplicationPrivate::setSingleInstanceByDbus: 203] register servic
e failed: QDBusError("org.freedesktop.DBus.Error.Disconnected", "Not connected to D-Bus server")
[2018-11-29, 21:00:30.507] [Error &#160;] [main.cpp=&gt;main: 143] As well as the process is running

But no window opens.


#13

Yup, I still have this issue as well. No idea for a fix yet.


#14

Btw. I just tested it on Antergos with Deepin desktop.
It also doesn’t work on that system, same messages in terminal.

So it seems to be a bug of deepin-clone itself or the archlinux package.


#15

Can you submit a bug somewhere to have it looked at or fixed?


#16

#17

Oh awesome thank you very much! Didn’t realize it was that easy! Hopefully this gets looked at and resolved in the future.


#18

Sadly nothing seems to happen on GitHub. Sure, maybe they need some time… it’s ok.
But I need a program for backups.

Does anyone know a good program for taking full disk images, without cloning all the empty space? (“dd” is not an accepted answer, also not in combination with gzip, because it still reads and writes the full disk, which takes ages.)
I had hope in Deepin-Clone, but this one doesn’t work.

The only working tool I found so far is clonezilla. But Clonezilla can not output to an already mounted folder. Since my target device where I want to save the backup is already mounted, I always have to reboot and use clonezilla live to backup. So it’s a horrible solution, but the only full disk backup image solution I found so far.
Anyone knows a better one?


#19

timeshift I use :wink:

I wrote in post #4


#20

Can timeshift now make images and clone disks, including partition table…?
Last time I tryed timeshift it did only backup the files, but not the whole disk with partitions as image.