Deepin 18.02 not recognizing wireless network password


#21

I wonder if this issue only occurs if the install is done from a live usb session. I just did a Deepin install 2 days ago using Manjaro Architect and I did not see this behavior. The dialog box from the dock took my wifi password and connected to my network with no problems.


#22

At least for me yes, i installed from live usb number of times, but even on same machine it happens not every time…

Haven’t tried direct install though


#23

Yes indeed. I’ve installed it last night and this problem solved after installing it on a partition of my hd. BTW Deepin works quite well now and looks good.


#24

You’re Doing it wrong.
ControlCenter ->Network -> Wireless Network
and then click the arrow next to your wifi ssid/name.

This should fix the problem.


#25

I had this exact same bug today while running Manjaro Deepin from the live USB, but I can confirm that following the steps pointed out by @thesneakyotter I was able to connect to WiFi, and that the bug is gone in the installed version


#26

Thanks. This worked perfectly for me, on live usb. I’m new to Linux in general and to Manjaro Deepin in particular, so I wanted to try it out before installing.
Logged out (Newbies like me: click the big red lightning bolt in the dock tray), and upon logging back in (password is manjaro), I could finally connect to wifi using the same (correct) password I had been using and had been rejected like 5 times.


#27

Yeah, Deepin is a work in progress. It’s in active upstream development with frequent updates. While it’s great for end users, it can also sometimes be a bit edgy in it’s behavior some times.

No doubt, it’s a great looking distro!

GM


#28

I am having this issue right now; makes it very difficult to test drive. I have not really used Deepin and wanted to run it for an hour or two, but it’s kind of pointless if you can’t reach the network… let alone Internet.

Also, it seems it’s worse for me because there appear to be nothing that looks “broken”, the correct window comes up and ask for a password both in control center and from the panel. It just won’t accept it.


#29

You’re right this issue should be fixed ASAP specially for those who want to try Deepin with a Live USB.


#30

Did the workarounds suggested earlier in theis thread not work for you?

The fix is rather simple for most people, unless this bug has gotten worse recently.


#31

They do but if something doesn’t work out of the box is broken. Many potential “average” users would just give up without any further testing.


#32

Did you file a bug report at the Deepin development bugtracker. Manjaro has absolutely no connection to the development of the deepin desktop. The appropriate course of action is to report any bugs to the project responsible for its development. Why are you whining about this on the Manjaro forum. This is a Deepin issue, not a Manjaro issue.


#33

See if the problem has already been reported.


#34

I’m not whining. I’ve tried Deepin official installer and I did not like the distro at all but this problem didn’t occur. I love my Manjaro Deepin, it works like a charm but this bug should be fixed. Ok?


#35

Yes, there is a bug report from @oberon https://github.com/linuxdeepin/developer-center/issues/805

Thanks


#36

Well it certainly comes off as whining when Manjaro has absolutely nothing to do with deepin development. Repeatedly posting about this issue here is like complaining at a Chevy dealership that the Ford you got for free is defective.

You are complaining at the wrong place. I just read the thread Oberon opened, and there are many responses claiming this is only intermittent, or does not affect them, or is not reproducible. If you want this issue addressed then register on their forum and let them know that this issue affects you as well. The more users that complain that this bug is widespread the more likely i will be fixed.

If you want to use a free Linux OS then YOU are the one responsible for reporting any bugs. Otherwise the bug is unlikely to get fixed if it is deemed as not affecting many users. Get on it.


#37

I will report. Good point, thank you.