Deepin 18.02 not recognizing wireless network password


#1

I’m experiencing a very strange problem when trying to install the new Manjaro Deepin release. When I try to log in to my wireless network it does not recognize the password (yes, I have checked multiple times to be sure I am entering the correct password).
I re - downloaded the ISO and tried again and I am still experiencing the same problem.
All of my other devices are working on my network and I logged out of them and logged back in using my password without issues.


#2

Did you check the router settings?
Has the IP of the computer changed?
Is the PC in the router network enabled?

Please post output from
inxi -Fxxxz


#3

Try setting a static IP address through the router via MAC address association. Make sure you have the correct security authentication set. Disable security authentication entirely to see if you can connect without requiring a password.


#4
$ inxi -Fxxxz
System:    Host: jeffrey-pc Kernel: 4.20.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X705UDR v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X705UDR v: 1.0 serial: <filter> UEFI: American Megatrends v: X705UDR.306 date: 11/27/2017 
Battery:   ID-1: BAT0 charge: 37.5 Wh condition: 37.3/42.1 Wh (89%) volts: 11.5/11.5 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Not charging cycles: 23 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 700 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 693 2: 722 3: 727 4: 700 5: 742 6: 721 7: 700 8: 700 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.3 driver: intel compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.3.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.20.0-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: r8822be v: kernel port: c000 
           bus ID: 03:00.0 chip ID: 10ec:b822 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.16 TiB used: 47.53 GiB (4.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: SDM4 scheme: GPT 
           ID-2: /dev/sdb vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: A020 
           scheme: GPT 
           ID-3: /dev/sdc type: USB vendor: Kingston model: DataTraveler 2.0 size: 14.45 GiB serial: <filter> rev: 1.00 
           scheme: MBR 
Partition: ID-1: / size: 122.54 GiB used: 28.13 GiB (23.0%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 34.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 240 Uptime: 6h 26m Memory: 15.55 GiB used: 3.51 GiB (22.6%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: yakuake inxi: 3.0.28 


#5

Your wm is kwin_x11, mine is DeepinWM

System:    Host: deepin Kernel: 4.20.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.8 tk: Qt 5.12.0 
wm: DeepinWM dm: LightDM 1.28.0 Distro: Manjaro Linux

Look in manjaro settings manager if other driver possible.

That’s all I can say about it.


#6

Navigate directly to the control center and paste your network password there. Remember to also scroll down and hit “save” to activate your wifi connection.

For unknown reasons, entering your password in the small white pop-up isn’t working at the moment.

GM


#7

Did @oberon know that? :wink: :slight_smile:


#8

Something cookin’ with the recent Deepin release and passwords. On a fresh install, sddm also wouldn’t accept my user password. Unfortunately, that’s one that’s hard to work around. :grin:

On a lighter note, Deepin is doing some nice work, as is oberon.

GM


#9

Just to pile on, I’m having the same issue. If anyone finds a workaround, please let us all know…


#10

Do you read post #6?
Or fresh install??? :wink:


#11

I did see post #6. I have a extra “test” laptop I’m frequent switching between Manjaro DE’s (so fun!) and seeing Deepin was updated (which I liked a lot on last trial, but found to be buggy) I put it on a USB and booted from that. On the USB, going to the control center doesn’t allow you to paste in a password. Clicking it there only brings up the same broken small white window, which we all know doesn’t work.

So, yeah, I guess fresh install…

BTW: Looking forward to getting this sorted, as on first blush on the USB, the prior scrolling, screen closure, and shortcut bugs seem to be fixed.


#12

Hmmmmmm :unamused:


#13

Verachte nicht den Überbringer schlechter Nachrichten :wink:
ich habe kein WLAN für die PC Verbindung.


#14

I had the same issue while running it live from thumbdrive, but upon installation, my wifi password worked fine.

Granted, it should be fixed; I took a gamble in hopes that it would be okay after installation, and it was. Whew!


#15

That’s very helpful to know. I’ll give it a try and fully install. Thanks!


#16

Had the same issue. I logged out and logged back in, tried again and it worked. Once installed, the problem was gone.


#17

Yes, the problem with Deepin 18.02 is whenever you create a new wifi connection it says that password is wrong. I have found a command line fix for it. Open the terminal and use the following command:

sudo nmcli device wifi connect SSID-NAME password SSID-PASSWORD

Do it in the live environment and when asked for the password for sudo type in manajro


#18

I noticed that when accessing the network settings via the control-center the wifi password is accepted fine. I encounter the problem only with the popup-window from the systray. Something in that interface seems to be broken…
I have opened an issue in Linuxdeepin’s developer-center:


#19

This is annoying bug, but in order to have quickfix for people having this issue:
systemctl restart NetworkManager

At least in my case after that i could login and update.


#20

If the Network Manager popup prompt will not accept WiFi password, then try these workarounds.

One work-a-round is to install nm-connection-editor, and then enter password through the connection editor .

You can also run the nmtui utility in the terminal to connect.