Dec 02 Update & QCA9377 Wireless



I installed this update [Stable Update] 2018-12-02 - Kernels, Plasma, Mesa, Cinnamon, Gnome, Deepin, XFCE, Vulkan: in Majaro - i3 edition.

This broke my WIFI: Atheros QCA 9377 firmware fail. There are lots of threads about this Adapter on here in the past, but none for this update as yet.

In this scenario: Wireless adapter recognized by inxi, lspci, hwinfo, etc but not by iw link and more to the point, nw-applet showing nothing available.

After a long search (I’ll spare the details unless someone wants to know) for what had changed, I determined that the update brought in firmware-6. The previous setup used firmware-5

What I did to fix was just get rid of Firmware-6.bin in the hopes the system would pick up and use 5.

sudo mv /usr/lib/firmware/ath10k/hw1.0/QCA9377/firmware-6bin /media/[USBStick]
sudo reboot

After which, normal functionality was restored.

Hope this might help if someone else runs into this.

Also, please advise if there is a better or safer way of doing this (just getting rid of the offending file… ). I actually pulled the same stunt a few months ago on an AntiX system that got a new iwlwifi driver that didn’t agree.

Seems like a simpler solution than rolling back the install. But I am still a bit of a novice on hardware and firmware stuff, I would be happy to know if I am overlooking anything?

[Solved] QCA9377 Wireless device not working after upgraded Linux 4.14.85-1
Qualcomm QCA9377 802.11ac Issues

Which kernel do you use? On my side, it works fine with kernel 4.19 without doing downgrade of linux-firmware package or doing some shenanigans.

Now that you have a working adapter, maybe you could give it a shot.


Thanks for the tip… so the Firmware-6 probably be needed if I was running a later kernel?

I’m on 4.14.85-1.

I have not really delved into different Kernel version as a subject yet… Manjaro Setting Mngr has the option, I see to run … guess next time I am feeling brave, I will give it s shot.


I’m experiencing exactly the same issue, also on kernel 4.14.
However, I probably cannot upgrade to a new kernel now. 4.14 was selected on purpose three months ago since kernels >=4.15 had repeating issues when shutting down or going to hibernate/sleep mode (crashed and not performing shutdown/hibernate/sleep correctly). This was discussed in other distro forums (Ubuntu, CentOS) as well. For this reason, I started with Manjaro since I could choose the kernel. Seems I can get rid of this laptop…



Yes, that works. But: pacman will always reinstall the newer version whenever I run a system upgrade or install some other package. Thus, manually downgrading is only a very temporary solution…


I think moving the file is probably the easiest solution, other than making the file inaccessible (e.g. chmod 0 /usr/lib/firmware/ath10k/hw1.0/QCA9377/firmware-6bin).

This way a future package update might correct the issue and you don’t need to keep an older package on your system which you have to remember to skip.


Good advice… I now keep a list of such fringe tweaks for use during updates. We’ll see if it works next update :sunglasses:

closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.