Dead gui session in "alt+ctrl+F1" ! but normall in "alt+ctrl+F2"

Hi

I use Manjaro KDE
I have one nice problem :slightly_smiling_face:

When press alt + CTRL + F1, I see a blank screen with a cursor.

My GUI session av. in alt Ctrl F2 !

Also, in shutdown have a long delay for closing simple desktop session …

System:
  Host: mz-trx2 Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux
Machine:
  Type: Desktop Mobo: ASRock model: TRX40 Creator
    serial: <superuser required> UEFI: American Megatrends v: P1.70
    date: 05/29/2020
CPU:
  Info: 32-core model: AMD Ryzen Threadripper 3970X bits: 64 type: MT MCP
    cache: L2: 16 MiB
  Speed (MHz): avg: 2377 min/max: 2200/4549 cores: 1: 3611 2: 2113 3: 2057
    4: 2205 5: 2058 6: 2055 7: 2054 8: 3595 9: 2152 10: 2107 11: 2129 12: 4228
    13: 2057 14: 2058 15: 2057 16: 3235 17: 2195 18: 2059 19: 2057 20: 3600
    21: 2200 22: 2200 23: 2199 24: 2200 25: 2199 26: 2201 27: 2201 28: 2200
    29: 2664 30: 1962 31: 1966 32: 3358 33: 2854 34: 2198 35: 2065 36: 2083
    37: 2057 38: 2053 39: 2055 40: 3592 41: 2148 42: 2150 43: 2145 44: 3918
    45: 2196 46: 2196 47: 2198 48: 2195 49: 2193 50: 2112 51: 2071 52: 2202
    53: 2199 54: 2203 55: 2200 56: 2197 57: 2200 58: 2196 59: 2200 60: 2200
    61: 2420 62: 2079 63: 2089 64: 4044
Graphics:
  Device-1: AMD Ellesmere [Radeon Pro WX 7100] driver: amdgpu v: kernel
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting gpu: amdgpu
    resolution: 1: 3072x1728 2: 3072x1728
  OpenGL: renderer: AMD Radeon Pro WX 7100 Graphics (polaris10 LLVM 13.0.1
    DRM 3.44 5.17.9-1-MANJARO)
    v: 4.6 Mesa 22.0.4
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Generic USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion]
    driver: atlantic
  IF: enp69s0 state: up speed: 10000 Mbps duplex: full
    mac: a8:a1:59:5f:9f:fd
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlp70s0 state: down mac: 7a:55:52:17:da:83
  Device-3: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp71s0 state: down mac: a8:a1:59:5f:9f:ff
  IF-ID-1: docker0 state: down mac: 02:42:26:83:df:c6
  IF-ID-2: virbr0 state: down mac: 52:54:00:c3:bb:28
  IF-ID-3: virbr2 state: down mac: 52:54:00:4d:20:e2
  IF-ID-4: virBrigeDefNAT state: down mac: 52:54:00:fb:4c:d3
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 18.19 TiB used: 7.92 TiB (43.5%)
  ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket 4.0 Plus size: 3.64 TiB
  ID-2: /dev/nvme1n1 vendor: Sabrent model: Rocket 4.0 Plus size: 3.64 TiB
  ID-3: /dev/nvme2n1 vendor: Sabrent model: Rocket 4.0 Plus size: 3.64 TiB
  ID-4: /dev/sda vendor: Samsung model: SSD 860 EVO 4TB size: 3.64 TiB
  ID-5: /dev/sdb vendor: Samsung model: SSD 860 EVO 4TB size: 3.64 TiB
Partition:
  ID-1: / size: 491.14 GiB used: 248.26 GiB (50.5%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 96 MiB used: 37.9 MiB (39.4%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 76.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1232
Info:
  Processes: 881 Uptime: 23m Memory: 125.7 GiB used: 7.19 GiB (5.7%)
  Shell: Zsh inxi: 3.3.16

And what about Ctrl+ Alt + F3?

Normal console session …

Did you use the “Switch User” option recently?

That’s an SDDM bug from last year, and it has already long been fixed. I’m guessing you don’t use or update your system very often. :man_shrugging:

In current boot NO, is single user workstation

My system is full update …

That’s because:

There is blackened sddm running on tty1. For some reason. Switch to x11 and “problem” will disappear.

1 Like

Hi zbe

How properly way to migrate Wayland and kill x11 ?

My default session is Wayland …

Doubt it was default when you installed Plasma.
If everything is working fine for you, you don’t have to.
You can switch between X11 and Wayland on SDDM login screen, bottom left corner.

Edit: Wait, after re-reading your comment again, I’m not sure what you are asking anymore:

But Sorry I Confused :face_with_spiral_eyes:

  1. what I have dark session in ALT Ctrl + f1 ?
  2. If switch session between X11 and Wayland, we have dark session in (1)

Note, this dark session (ALT Ctrl + f1) keep after reboot and login in default Wayland session without any login or switch to X11

I’m just telling you that at the moment it is designed like that if you are using wayland. And if it bothers you, switch to X11.

Hi zbe

Thanks for your comment
can tell me source info to read more about this limitation in sddm or KDE in Wayland

  1. Dead GUI session : Ctrl + alt + f1
    2.long time in shutdown because long delay for closing simple desktop session.