dconf-Warning when trying to open Gedit from terminal

When I try to open some file with Gedit, I will get below warnings in terminal and then file opens. How can I get rid of it.

~ >>> sudo gedit abc.txt                                                                                                                                     

(gedit:5553): dconf-WARNING **: 19:09:11.521: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=a18b4af79e9e40d7aaad5fc54ba4078a --binary-syntax --close-stderr”: Child process exited with code 1

(gedit:5553): dconf-WARNING **: 19:09:11.528: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=a18b4af79e9e40d7aaad5fc54ba4078a --binary-syntax --close-stderr”: Child process exited with code 1

** (gedit:5553): WARNING **: 19:09:11.729: Error loading plugin: libhspell.so.0: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.732: Error loading plugin: libvoikko.so.1: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.732: Error loading plugin: libnuspell.so.3: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.733: Error loading plugin: libaspell.so.15: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.736: Error loading plugin: libhspell.so.0: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.737: Error loading plugin: libvoikko.so.1: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.737: Error loading plugin: libnuspell.so.3: cannot open shared object file: No such file or directory


** (gedit:5553): WARNING **: 19:09:11.737: Error loading plugin: libaspell.so.15: cannot open shared object file: No such file or directory

dconf warning is because you’re running gedit as root.

Don’t run GUI apps as root.

GUI as root.

Pro tip: not a good idea.

Plugins are for various spell checkers (ie: hspell is a Hebrew spell checker). If you don’t have it installed, no biggie.

1 Like