DaVinci Resolve won't open despite having opencl-nvidia installed

I’m trying to run DaVinci resolve because I need to make minor edits to videos as I’m teaching online this semester. When I run or try to open DaVinci Resolve, it will spin the loading wheel for a few seconds and quit the process without an error message before a window opens.

I looked and found this davinci-resolve-checker and when I run it, I get the following output:

./davinci-resolve-checker.py 
DaVinci Resolve checker 1.2.1
You do not have opencl-nvidia package. Install it, otherwise you could not use D.R. Even if you are planning to use cuda, opencl-nvidia will be installed as its dependency.

yet when I try to install opencl-nvidia using yay, I’m met with the followingopencl-installed

which shows I have opencl-nvida-440xx (the most current available but not the most current that is released – I’m unaware of how to notify via yay that there is a newer one available.

Hello,

If you switched to testing or unstable and installed the video-nvidia-450xx drivers via the mhwd, then you have to install opencl-nvida-450xx via pacman or pamac command/Ui.
If you are still on stable branch and have the video-nvidia-440xx driver installed then you need opencl-nvida-440xx package.
The versions need to match. There is no opencl-nvidia package and using yay (is an AUR helper) would require anyway to use the full name of the package from AUR.

If you are looking for opencl-nvidia-beta version 450.57 then you have to specify it, but i do not recommend. Is not quite clear what you want to achieve here, as for the error given by the
davinci-resolve-checker.py please make sure you also have rebooted the system if you made changes to the drivers and opencl packages.

I appreciate the response as always Bogdan. I don’t fully understand the points you’re bringing up, so it’ll take me a couple of hours to get to the point where I can poke around a bit and make sense of them :sweat_smile:, but once I get to that I’m sure it’ll work fine!

edit2: I was using kernel 5.9, which broke the way NVIDIA drivers work and it’ll be about half a month until NVIDIA has the drivers working there. I switched back to 5.8 and OpenCL is detected.

edit: scratch that, clinfo can’t find anything either and Darktable is not detecting OpenCL. What am I missing here? all the corresponding packages are installed O.o

I’m having the issue but with the actual program. Thing is, I do have the driver working, games run and Darktable uses opencl just fine, but Davinci still can’t find my GTX1050ti, it’s a great headscratcher. The log says:

Urgent message: CRITICAL_PREF: DaVinci Resolve could not find any OpenCL capable GPUs. Would you like to review and update your DaVinci Resolve Hardware Configuration? ||Please ensure that appropriate GPU drivers are installed and your DaVinci Resolve hardware is configured appropriately.
[0x7f428ce6b640] | GPUManager | ERROR | 2020-10-29 23:26:55,171 | CRITICAL_PREF: DaVinci Resolve could not find any OpenCL capable GPUs. Would you like to review and update your DaVinci Resolve Hardware Configuration? ||Please ensure that appropriate GPU drivers are installed and your DaVinci Resolve hardware is configured appropriately.

Any suggestion on where I should look?