Davinci Resolve doesn't open

I tried to install Davinci Resolve in manjaro, as the program is not in pamac, I installed it via aur using yay: yay -S davinci-resolve I installed everything just right, but when opening the presentation screen appears, after about 15 seconds the program closes and together with it all the processes related to it. I have already restarted the computer and tried to open the program again, no improvement. I tried to get some log in the terminal but the program does not answer the commands: davinci-resolve; davinciresolve; davinci; resolve; I searched the internet and some results I got was that this could be caused by the absence of some depedences so I installed all of these: lib32-opencl-mesa; libclc; ocl-icd; but the problem persists. P.s: opencl-mesa was installed before I tried to install Davinci Resolve for the first time.

I tried: /opt/resolve/bin/resolve (I’m still a noob here, this is my first post ever so I don’t know where to upload a log file in xml format).

$ /opt/resolve/bin/resolve        
ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
log4cxx: No appender could be found for logger (BtCommon).
log4cxx: Please initialize the log4cxx system properly.
16.2.7 (#010) Linux/Clang
Main thread starts: B738A580
[0x7f26b738a580] | Undefined            | INFO  | 2020-10-05 15:31:14,921 | --------------------------------------------------------------------------------
[0x7f26b738a580] | Undefined            | INFO  | 2020-10-05 15:31:14,921 | Loaded log config from /home/denielton/.local/share/DaVinciResolve/configs/log-conf.xml
[0x7f26b738a580] | Undefined            | INFO  | 2020-10-05 15:31:14,921 | --------------------------------------------------------------------------------
[1]    10364 killed     /opt/resolve/bin/resolve

and this is my hardware information

$ inxi -Fxz
System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: GNOME 3.36.6 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2006 date: 11/13/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81470 
  Speed: 2778 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 2858 2: 1577 
  3: 1369 4: 1539 5: 2692 6: 1372 7: 1373 8: 1546 9: 2477 10: 1352 11: 2964 
  12: 1373 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus ID: 08:00.0 
  Display: x11 server: X.org 1.20.9 driver: amdgpu,ati 
  unloaded: modesetting,radeon resolution: <xdpyinfo missing> 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.38.0 
  5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 08:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.3 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 447.13 GiB used: 33.54 GiB (7.5%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition:
  ID-1: / size: 48.97 GiB used: 15.53 GiB (31.7%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 389.64 GiB used: 18.01 GiB (4.6%) fs: ext4 
  dev: /dev/sda3 
Swap:
  ID-1: swap-1 type: file size: 1024.0 MiB used: 0 KiB (0.0%) 
  file: /swapfile1 
Sensors:
  System Temperatures: cpu: 40.5 C mobo: N/A gpu: amdgpu temp: 41 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1099 
Info:
  Processes: 343 Uptime: 48m Memory: 15.63 GiB used: 2.55 GiB (16.3%) 
  Init: systemd Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1092 
  Shell: Zsh v: 5.8 inxi: 3.1.05

wait what? I still need help

sorry dude, i saw you using amd, i was talking about nvidia prime :slight_smile: so cant get any sugestion for you.

Hello,

Is an AUR package, moved the topic to the right category because of that.

There are a lot of such topics on different forums. Most suggest the install of ocl-icd that you already did. Have you also tried installing lib32-ocl-icd ?

In cases like this we have no much support to give and probably their forum would be the best place to go and ask for support. Not being dismissive, but … we can’t possibly know much about it.
Have you seen this?
https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=56878&sid=ae6948916546344714a7c1892f7d167d&start=1800

Have look here: DaVinci Resolve - ArchWiki

opencl-mesa does not work with DaVinci_Resolv. You need opencl-amdgpu-pro-orca or opencl-amdgpu-pro-pal to let it work.

Alright, thanks for the correction, I will pay more attention next.

Yes, it was already installed before trying to install Davinci.

Thank you mate, do I need to remove anything to install those packages or can they work simultaneously with my current drivers?

Yes, you need to remove opencl-mesa before installing opencl-amdgpu-pro-*

Also have look here for using the proprietary OpenGL if needed: AMDGPU PRO - ArchWiki

2 Likes

Good summary of the discussion from the link i posted from their forum. Thanks for pointing the OP to that direction! :+1: