DaVinci Resolve does not preview media even after following ArchWiki guide on AMD drivers

Hi everyone,

I installed DaVinci Resolve 17.4.2 (free) using the official installer.

I was following this ArchWiki post and installed DaVinci Resolve Checker. The checker was asking me to uninstall opencl-mesa which I did (I removed JUST this package).

I also went ahead and uninstalled all open source AMD drivers, so it looks like this

Then I installed: xf86-video-amdgpu, xf86-video-intel, and opencl-amd as the Archwiki recommends.

Now the Resolve checker writes

Locale unavailable: en_AU, using en_US instead
Using locale en_US
DaVinci Resolve checker 2.4.1
Installed DaVinci Resolve package: 
Chassis type: laptop
Installed OpenCL drivers: opencl-amd
Presented GPUs:
        Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] (kernel driver in use: amdgpu)
        Picasso (kernel driver in use: amdgpu)
OpenGL vendor string: AMD

You have several AMD GPUs. I am confused. Which one do you intend to use?

I am not sure what to do about this.

The problem I have is that when I load media into DR, it cannot play them. They are blank

Also playing with different GPU settings in DR does not fix the problem

Here’s my system information, is there something wrong with my GPU drivers?

System:    Host: alpha-nitroan51543 Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Nitro AN515-43 v: V1.08 serial: <superuser required>
           Mobo: PK model: Octavia_PKS v: V1.08 serial: <superuser required> UEFI: Insyde v: 1.08 date: 12/24/2019
Battery:   ID-1: BAT1 charge: 20.0 Wh (50.3%) condition: 39.8/58.8 Wh (67.7%) volts: 14.4 min: 15.4
           model: Simplo 0x41,0x50,0x31,0x38,0x45,0x37,0x000E type: Li-ion serial: 000E status: Discharging
CPU:       Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen rev: 1 cache:
           L1: 384 KiB L2: 2 MiB L3: 4 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33550
           Speed: 1892 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 2395 2: 2235 3: 2390 4: 2394 5: 2395
           6: 2394 7: 2375 8: 2385
Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X]
           vendor: Acer Incorporated ALI RX560X 4GB driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67ef class-ID: 0380
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: Acer Incorporated ALI driver: amdgpu v: kernel
           bus-ID: 05:00.0 chip-ID: 1002:15d8 class-ID: 0300
           Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-1:2 chip-ID: 0408:a061 class-ID: 0e02
           Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
           alternate: fbdev,vesa resolution: 1: 1920x1080 2: 1920x1080~60Hz s-dpi: 96
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.42.0 5.15.2-2-MANJARO LLVM 13.0.0) v: 4.6 Mesa 21.2.5
           direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Acer Incorporated ALI
           driver: snd_hda_intel v: kernel bus-ID: 05:00.1 chip-ID: 1002:15de class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel
           v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169
           v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: down mac: 08:97:98:76:12:ef
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel
           bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
           IF: wlp4s0 state: up mac: e8:d0:fc:8a:ac:f1
Bluetooth: Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 3-2:2 chip-ID: 04ca:3016 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 418.33 GiB (87.7%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1114 size: 476.94 GiB speed: 15.8 Gb/s
           lanes: 2 type: SSD serial: 192534800789 rev: 20180000 temp: 44.9 C scheme: GPT
Partition: ID-1: / size: 468.16 GiB used: 418.33 GiB (89.4%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap:      ID-1: swap-1 type: file size: 14 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 286 Uptime: 37m wakeups: 1 Memory: 13.66 GiB used: 4.32 GiB (31.6%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 clang: 13.0.0 Packages: 1787 pacman: 1780 flatpak: 7 Shell: Bash v: 5.1.8 running-in: konsole
           inxi: 3.3.09

Can someone help me please?

EDIT: I’m trying to completely remove the open source AMD drivers by running the command:

sudo mhwd -r pci video-linux && sudo mhwd -r pci free 0300 && sudo mhwd -a pci nonfree 0300  && sudo update-grub

Then I restart. But when I run

glxinfo | grep "OpenGL vendor string" | cut -f2 -d":" | xargs

I still get ‘AMD’ which means I’m on the open source drivers. What am I doing wrong? I want to switch to the proprietary drivers.

You may be aware of that already, but DaVinci Resolve doesn’t always accept all video formats (even if it allows them in the media bin), however, they can be added with the ‘Optimise Media’ function.


I tried that, didn’t work with any of my media files. Also I couldn’t find the

Right-click clip and select “Generate Optimized Media”.

that the guide was referring to.


Btw my media files are typically .mp4 with the following format

Resolution: 1280 x 720
Aspect ratio: 1.77778
Format: h264
Bitrate: 113 kbps
Frames per second: 29.970030
Selected codec: h264

Intrestingly, when I right clicked the media and selected ‘reveal in media storage’ I get the following:


But the file is there, and if I right click and select ‘Open file location’ it correctly opens the folder it’s located…

I have this media storage selected in the settings

Try with files and folder names without space. Example: youtube_subscribe instead.

Does not fix the problem unfortunately :frowning: