Datenbank synchronisieren geht nicht

Hallo,
ich bin am verzweifeln und bevor ich mich ganz von Manjaro trenne, ein letzter Strohhalm hier und ein Hilfeschrei!
Es ist schon der zweite USB mit Manjaro drauf - als fest installiert, den ersten habe ich wegen des gleichen Fehlers schon mit einer anderen Distri versehen.
Was mich wundert, lange Zeit war Ruhe mit Manjaro, ich hatte es ja auch nur zum überwiegend surfen benutzt. Ich hatte auch schon einige Aktualisierungen gemacht.
Nun will ich wieder die angegebene Aktualisierung machen und es geht nicht.
Bei jedem Versuch mit " sudo pacman - Su " oder die vielen anderen, ich bekomme immer nur, dasd dcie Datenbank nicht gefunden wird oder das synchronisieren nicht geht. Ich habe auch mit löschen von Paketen versucht, nix geht!

Aber noch die große Bitte = wenn Ihr mir helfen wollt, bitte so einfach wie möglich, ich bin ein technisches Nichts, und steh auch öfters auf dem Pneu.

Ach ja, mit Octopi habe ich es auch versucht, geht auch nicht.

Ich habe : Manjaro Lysia 20.0.1 xfce

hier ein Screen vom Terminal:

Fehler: Konnte Datei 'custom.db' nicht von Platte übertragen : Couldn't open file /home/custompkgs/custom.db
Fehler: Konnte custom nicht aktualisieren (Fehler in der Bibliothek für Downloads)
Fehler: Fehler beim synchronisieren aller Datenbanke

Vielleicht habt Ihr die Geduld usw. und könnt mir helfen

manton

Hallo
Lösche den lokalen Cache 'sudo pacman -Sc'
aktualisiere die spiegelserver und wähle die schnellsten davon aus 'sudo pacman-mirrors --fasttrack '
danach das update starten 'sudo pacman -Syyu'

Es gibt für solche Anwendungen wirklich bessere Distributionen als Manjaro. Das sollten nur Hardcore Fans machen, die unbedingt ein besonderes Feature von Manjaro benötigen.

Wenn du dich als so ein User siehst, ist Manjaro nicht wirklich die beste Wahl. Auch hier gibt es Distributionen oder Unternehmen die dich besser unterstützen können.

Falls die Befehle von @olli nicht helfen sollten.

Poste doch bitte mal die pacman.conf

cat /etc/pacman.conf 

und auch eine Auflistung von den vorhandenen Ordnern und Dateien im Ordner /etc/pacman.d

ls -l  /etc/pacman.d

Und Bitte Poste die Terminal Ausgaben als formatierten Text. Das heißt den Terminal Text in deinen Betrag kopieren, den Text markieren und dann auf den </> Knopf klicken.

Untitled

hallo olli, lieben Dank für Deinen Rat, das hatte ich schon öfters versucht, auch jetzt wieder von Dir = nein - hat nix genützt

hallo xabbu, auch Dir vielen Dank. Du hast schon recht mit anderer Distri - ich habe bisher LM Mint Mate und mal mit Deepin versucht, der Mate ist momentan der einzige, würde aber doch gerne nen zweiten Stick haben, und bisher lief ja auch das Manjaro richtig flott - tja bisher!

vielleicht hast du noch ne Idee für ne Distri für USB die flott ist?

[antonmj@anton-tobefilledbyoem ~]$ cat /etc/pacman.conf

/etc/pacman.conf

See the pacman.conf(5) manpage for option and repository directives

GENERAL OPTIONS

[options]

The following paths are commented out with their default values listed.

If you wish to use different paths, uncomment and update the paths.

#RootDir = /
#DBPath = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile = /var/log/pacman.log
#GPGDir = /etc/pacman.d/gnupg/
#HookDir = /etc/pacman.d/hooks/
HoldPkg = pacman glibc manjaro-system

If upgrades are available for these packages they will be asked for first

SyncFirst = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta = 0.7
Architecture = auto

Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup

#IgnorePkg =
#IgnoreGroup =

#NoUpgrade =
#NoExtract =

Misc options

#UseSyslog
#Color
#TotalDownload

We cannot check disk space from within a chroot environment

CheckSpace
#VerbosePkgLists

By default, pacman accepts packages signed by keys that its local keyring

trusts (see pacman-key and its man page), as well as unsigned packages.

SigLevel = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

NOTE: You must run pacman-key --init before first using pacman; the local

keyring can then be populated with the keys of all official Manjaro Linux

packagers with pacman-key --populate archlinux manjaro.

REPOSITORIES

- can be defined here or included from another file

- pacman will search repositories in the order defined here

- local/custom mirrors can be added here or in separate files

- repositories listed first will take precedence when packages

have identical names, regardless of version number

- URLs will have $repo replaced by the name of the current repo

- URLs will have $arch replaced by the name of the architecture

Repository entries are of the format:

[repo-name]

Server = ServerName

Include = IncludePath

The header [repo-name] is crucial - it must be present and

uncommented to enable the repo.

The testing repositories are disabled by default. To enable, uncomment the

repo name header and Include lines. You can add preferred servers immediately

after the header, and they will be used before the default mirrors.

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired

If you want to run 32 bit applications on your x86_64 system,

enable the multilib repositories as required here.

Include = /etc/pacman.d/mirrorlist

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
[custom]
SigLevel = Optional TrustAll
Server = file:///home/custompkgs[antonmj@anton-tobefilledbyoem ~]$

[antonmj@anton-tobefilledbyoem ~]$ ls -l /etc/pacman.d
insgesamt 16
drwxr-xr-x 5 root root 4096 3. Mai 15:47 gnupg
-rw-r--r-- 1 root root 7130 26. Mai 20:52 mirrorlist
[antonmj@anton-tobefilledbyoem ~]$

Tippe oder füge den Code hier ein

ich hoffe ich habe es richtig gemacht

manton

Naja war nicht so hundertprozentig richtig, aber den wichtigen Teil kann man erkennen.

In deiner pacman.conf ist das Beispiel ([custom] ) Repository eingeschaltet. Dieses Repository musst du deaktivieren.

Du musst die pacman.conf dazu mit einem Text Editor bearbeiten.

Im Augenblick sieht die Datei am Ende noch so aus:

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
[custom]
SigLevel = Optional TrustAll
Server = file:///home/custompkgs

Du musst vor die letzten drei Zeilen einen Lattenzauen machen # .

Am Ende sollte es so aussehen:

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
1 Like

xabbu hat es erkannt. mach es wie @xabbu empfohlen hat. du musst den [custom] eintrag löschen. wo sich die frage stellt wie der da überhaupt auskommentiert wurde.

hallo, auch da krieg ich's mit den Nerven, ich hab die Lattenzäune gemacht aber beim schließen wird " speichern gefordert, tue ich das kommt " Die Datei /etc/pacman.conf konnte nicht gespeichert werden!
u.a. fehlende Zugriffsrechte

mmh wie mach ich das dann mit Zugriffsrecht ? bisher nicht gebraucht

und ich hab noch ne Datei gesehen, weiß aber nicht, ob das mit zusammen hängt?
noch ne " pamac.conf "

1 Like

den editor beim start mit sudo aufrufen also ' sudo Editorname /etc/pacman.conf'

hallo olli und xabbu, ganz dolle !

Riesigen Dank an Euch, hat jetzt prima geklappt.
Und falls zufällig Euch ne flotte andre Distri für mich einfallen solltet, sehr gerne.
Werde aber erst Mal Manjaro noch ! weiter benutzen.

Lasst es Euch gut gehn und

DANKE!
manton

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by