Database Error - Latest Update for Manjaro Gnome

I have tried this on multiple networks. One of them I did not know would block Linux servers and linux related forums (like this forum). I tried on the data of my phone, and that similarly did not work. I connected to a business network that works perfectly fine, and once again I received the same error. I have cleared the cache, to no avail. I have sorted through a mirror list and it has only failed to connect to any mirror. I am at a complete loss and I am wondering if I need to go ahead and download the most recent updated Gnome and reinstall.

Edit: I should also mention that I have a dual boot. My other one is Manjaro KDE and updating it goes smoothly. This makes the Manjaro Gnome a little bit of a mystery for me.

Here is the error that my terminal produces:

sudo pacman -Syu                                                
[sudo] password for shbryan28: 
:: Synchronizing package databases...
error: failed to synchronize all databases (no servers configured for repository)
sudo pacman-mirrors -c country

Try one of them:

sudo pacman-mirrors --country-list   

This is what I get:

sudo pacman-mirrors -c country                                 1 ✘ 
[sudo] password for shbryan28: 
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: ht;tps://
::INFO => Mirror status: ht;tps://
::WARNING Option 'c/--country' :  'c/--country' : 'unknown country'
::INFO Available countries are
Australia, Austria, Bangladesh, Belarus, Belgium, Brazil, Bulgaria, Canada, Chile, China, Costa_Rica, Czechia, Denmark, Estonia, Finland, France, Georgia, Germany, Global, Greece, Hungary, India, Iran, Italy, Japan, Kenya, MENA, Netherlands, New_Zealand, Norway, Philippines, Poland, Portugal, Russia, Singapore, South_Africa, South_Korea, Spain, Sweden, Switzerland, Taiwan, Thailand, Turkey, Ukraine, United_Kingdom, United_States, Uruguay

As you can read… you have to replace country with a real country name. :smiley:

I tried this and the text stays red.

Here’s what I did:

c/--United_States                                                ✔ 
zsh: no such file or directory: c/--United_States
 c/--Phillipines                                              127 ✘ 
zsh: no such file or directory: c/--Phillipines

okok… slowly… I see you are a bare newbie.

Run this to get a list of available countries:

sudo pacman-mirrors --country-list   

Then you copy the name there and write it like that:

sudo pacman-mirrors --country Australia

You can also run this, to call all available countries:

sudo pacman-mirrors --country all

Yes, I am still definitely on the learning track. My husband is the one who got me into Linux and it has been a great learning curve so far. :grin:

This seems to have done the trick. It is downloading just fine now. It is on the biggest package slowly getting there, and this is the farthest I’ve been able to get it to. I appreciate the help. :grinning: :fist:

Welcome to the forum! :wave:

Please see:

I’ve fixed it for you this time. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.