Data corruption detected during mkinitcpio, how to proceed?

I just ran sudo pacman -Syyu from TTY on one of my kids’ machines and it borked with a Data corruption detected during the final mkinitcpio phase of the update. See photo.

I can’t cancel out of the process and I can’t change to another terminal. No snapshots either, it’s an old default ext4 straight to disk install.

Any advice on how to proceed?

Your hardware e.g. CPU, RAM or disk is most likely damaged.

do you use proxmoxx or any other virtualisation ?
any encryption that you use ?
some infos are helpful.

Disk maybe, yes.

No, nothing like that. Like I said, bare metal Ext4 install without any snapshotting, encryption of virtualisation.

you can try to chroot the system

Followed by running, or getting a SMART check on the drive you mentioned could be faulty. Or from the Live environment before you enter a chroot environment:

sudo smartctl --all </dev/path>

Where </dev/path> is the path to the drive you want to check, /dev/sdb, /dev/nvme0n1, or similar.

Wow… I am flabbergasted I managed to recover.

I hard powercycled the machine and it boots to the graphical login screen. .o0(Ploink?) I saw a boatload of fixing/removing orphaned nodes flashing by, but that’s what you get if shutdown fails.

I go into the TTY, install smartmontools, run smartctl and there are no errors, none of parameters are out of whack (in fact, they’re all at their mininum, mostly zero). I delete Snap, because I hate it messing with mountpoints. I run makeinitcpio and it finishes normally. Reboot, login… dang, desktop does weird things, loads partially, but is fairly broken. Long story short, forcing reinstall of the cinnamon package fixes the desktop.

So, I am fairly sure it is not the Samsung Evo 860 SSD, but the kid says the machine occasionally hangs/crashes and he just powercycles it, but never told me. Might be memory then… running Memtest now.

Marking this thread fixed since the machine, at least for the moment, is up and running again.


so it’s highly possible that the system was hard interrupted while it was still writing to disc. that explains the disk-errors.
eventually you fixed it, that’s all that matters.

1 Like

Then you don’t understand what the numbers mean.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.