Dark mode not working in Cinnamon 6.2.0

Anyone else finding that dark mode no longer seems to work with the update to Cinnamon 6.2.0? I haven’t made any changes but now it just seems permanently stuck on light mode.

When I just tried, I could only change it by going to System Settings → Themes
and there switching from Advanced Settings to Simplified Settings
and then (the Style was set to custom) setting the Style to Adwaita.
Then the switching back and forth works, but only between “Mixed” (which is effectively “Light”) and “Dark”.
I prefer dark, though, so this was just a try and I will immediately revert that to what it was.

Thanks for the reply.

When I go to Simplified Settings, it just shows the Style as being Custom and then the options for Mixed, Dark or Light in Appearance are all greyed out and can’t be selected.

Previously, I would just go to Advanced Settings and ensure that it was set to Prefer Dark Mode, but now it just seems to ignore that.

… then change that

that’s what I did, as I said :man_shrugging:

Custom is the only Style option it gives me.

Mine is a fresh install (in a VM) - maybe two to three weeks old.
Prior to this little experiment I did nothing to adapt anything.
I can just describe what I did - if the same has different results for you, I cannot help. Sorry.

That’s OK. Maybe someone else will know.

You could try the darkmode app

Do you mean the Dark Mode applet? I just tried that and it still displays everything in Light Mode :frowning:

Try cinnamon 6.2.2-1 coming along shortly, there’s a fix for it.

2 Likes

Ooh, thanks a lot for that. Firefox is now working again in Dark Mode :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.