Custom font for osd_cat? xfontsel font bug! Or other method of fullscreen overlay maybe?

I’ve been looking for easy to understand docs on how to set custom font for osd_cat. Didn’t found any.

Current script:
while true; do date; sleep 1; done | osd_cat --align right --pos top --lines 1 --delay 2

so the default value for font is
--font "-misc-fixed-medium-r-semicondensed--*-*-*-*-c-*-*-*"

I don’t understand what those cryptic line means. Most article I found are just copy paste of each other. Anyone has any idea on how to use osd_cat?

Tried to mess up with the parameter but mostly ended up with ABORT: Requested font not found or zsh: no matches found: -misc-fixed-medium-r-semicondensed--*-*-*-*-c-*-*-*

Say I have font, this one Upheaval Pro Font · 1001 Fonts in my system. Now what would be the parameter I should put? and how do I change the font sizes?

If anyone have better alternative for osd_cat that would be really great! I want an overlay clock for when I run some apps fullscreen. Like video games.
osd_cat default font is just way too small.

there is xorg-xfontsel that some forum post recommend but the software use letters from ancient civilization. I can’t understand it @.@

tried to use LC_ALL=C xfontsel but still the same.

hmm, ok looks like the problem are caused by my locale setting that has multiple locale for different things.
Using LC_ALL=en_US.UTF-8 xfontsel -print is working well.

so now xfontsel is usable.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.