Current Calamares and M-A problems

calamares
manjaro-architect

#1

Guys sorry for posting here I’m just not good with proper bugreporting activity.
Recently I have been playing with different file systems and found out that Calamares creates tmpfs /tmp bla-bla-bla 0 0 entry in fstab if installing on f2fs. I thought systemd has been handling this for quite a time, hasn’t it? I’ve also seen such entry in someone’s recent listing of his fstab but that person was using ext4 for his entire disk.
The other confuse is related to M-A (which is brilliant thing btw). After full installation and successful chrooting within the installer itself, exiting such chroot renders M-A unusable. It begins to show some text like [[… in response to key presses leaving no way to use options that are still listed like installer is ready for user actions and forcing a user to close the installer.
Sorry for this kind of messy feedback, I just felt I must report this somewhere.


#2

Surely, my 1 month old Architect install didn’t added any fstab entry for tmpfs (on ext4) and still get’s mounted by systemd with default options anyway (rw, nosuid, nodev). It won’t harm if Calamares adds it anyway, more easy if you want to change size or mount options?

Unfortunately I didn’t try to chroot afterwards so I can’t confirm that part.


#3

Can you be more specific? The intended functionality is so clunky that it might be indistinguishable from a bug. To return to the installer after chroot, you need to exit the chroot shell and run fg. The previous dialog screen is left drawn on the screen.


#4

Yes, the described behaviour is observed right after exiting chroot, so there is no way to enter fg, because pressing keys does nothing, it’s like when you install something via pacman and press some keys during the output of the running task, or like when you have problems with graphic drivers and being dropped to tty frozen on “Started some service” message: no tty prompt, no way to enter any command. That’s what I tried to describe:
^[[A^[[B, etc in response to key pressing.


#5

Some clarifications, @openminded You said

Do you mean to say that at installation system calamares creates the fstab entry?
Or do you mean to say, after installation, the installed f2fs OS has this at its fstab?

Because I do not get this fstab entry after installation.
I was testing out the new grub and installed all these (from iso boot - same iso) at the same time to an external drive. (ps: I will remove these installs but didn’t, yet)
After installation at installed OS, the respective fstab are

April -ext4
UUID=6d67915e-8add-41ec-a47b-18a574659b8a swap           swap    defaults,noatime 0 2
UUID=06FC-B2B0                            /boot/efi      vfat    defaults,noatime 0 2
UUID=86a038c9-3210-4832-965b-fe4693a4da6d /              ext4    defaults,noatime 0 1


May-Btrfs
UUID=06FC-B2B0                            /boot/efi      vfat    defaults,noatime 0 2
UUID=4609fa94-7ea7-4c21-85d2-02dcf52e06b5 /              btrfs   subvol=@,defaults,noatime,space_cache,autodefrag 0 1
UUID=4609fa94-7ea7-4c21-85d2-02dcf52e06b5 /home          btrfs   subvol=@home,defaults,noatime,space_cache,autodefrag 0 2


June - f2fs
UUID=06FC-B2B0                            /boot/efi      vfat    defaults,noatime 0 2
UUID=1f14dac9-c646-4224-97c6-634d44a4fd67 /              f2fs    defaults,noatime 0 1


no tmpfs /tmp bla-bla-bla 0 0 anywhere in all of them.


#6

I meant fstab in OS, installed on f2fs using Calamares. I had only /boot/efi, root and swap partitions selected, nothing else. All the other options were default.

As for ext4, pls take a look at this post, I doubt that that guy specified tmpfs explicitly.


#7

Okay, mine is same. But as shown, I did not get this tmpfs entry in fstab.

[edit] - I think you can safely comment out the tmpfs entry in fstab.
There is always a tmp mounted and will be deleted when shutdown.
You can check with ‘findmnt /tmp’ or just ‘mount’
I see no need for this fstab entry unless somebody here can tell us otherwise. Please do if so, thanks.


#8

[edit] - I think you can safely comment out the tmpfs entry in fstab.
There is always a tmp mounted and will be deleted when shutdown.
You can check with ‘findmnt /tmp’ or just ‘mount’
I see no need for this fstab entry unless somebody here can tell us otherwise. Please do if so, thanks.


#9

Are you using tty or some terminal? I’ll try to replicate the issue.


#10

I haven’t tried it in pure tty. In both cases it was m-a in a gnome-terminal launched from a icon on a panel, Gnome iso.

@gohlip
The reason why I am worried about that strange tmpfiles thing is data loss when I manually set that string in my fstab (on another test machine, ext4), logged out and logged in again. I could see files disappearing in my /etc directory. That was quite … educational and very odd at the same time. So I decided to share this experience and also point out that maybe this entry is still generated by the installer under certain conditions (f2fs + swap maybe?). Also I’m not claiming it is dangerous as is, all I know is that systemd does this and even more automatically, so there should be no need for installer to create such entry. As I understand it.


#11

Thanks!

Let’s find out if it is terminal specific or a new issue.


#12

I know tmp files are deleted at shutdown and that’s normal and correct.

That I don’t know. All my manjaro OS’s (not just the ones I mentioned to test recently) in the internal drives do not have this tmpfs entry in fstab whether they are ssd’s or spinning, uefi or bios-legacy, but most (I think) have swap automatically in them (some I removed to test, I think - I may forget). In short, I really don’t know why you and some have this entry and why some (like mine) do not. But I always install using booting up and install from isofiles and never from liveusb’s or disks. My other non-manjaro OS’s (and I have quite a few too) also do not have this tmpfs entry.