CUPS "Filter Error" Kyocera LP Series

From the Arch Wiki:

CUPS: "Filter failed"

A "filter failed" error can be caused by any number of issues. The CUPS error log (by default /var/log/cups/error_log) should record which filter failed and why. 

Well a “Filter Error” happened but logs don’t show anything abnormal

It looks like this is the driver.
Or rather, contains the driver.
A package available in the AUR.

Do you have that, or any dedicated driver, installed?

I did install this driver and tried using it … But no luck

Most Printers Supported by this driver are newer models … I gave up

rather easy to find out what driver they used - probably the very same



Hereyou go:

There are 2 steps that help when adding any type of new hardware to any Linux distribution.

  1. Turn the device off after installation, if possible. This applies to any device with a power switch.
  2. Turn the computer off, then back on. Don’t just reboot, turn it OFF. Then power back on.

I believe ubuntu was using PCL 6 Driver (I was a stupid linux user at that time ) but for some odd reason it doesn’t work on arch …
. I use windows 10 to print projects now :laughing::laughing::laughing:

I tried every single solution on web … They either support network machines or newer models or just bot generated website

Thank you guys for your efforts :point_right::point_left: :white_heart:

Stupid questions I know. Is the printer plugged in, connected and turned on?
And did you set up the printer to work with the program you’re printing from?
And did you restart the computer after installing the driver?

I did A Hard - Restart Evey Time (It means OS Goes Throught POST process eveytime) I Used New Driver
and I did Make The Printer Use PCL 6 Emulation
… printer connected throught usb

I figured as much, but its often the stupid things that people do that cause the most problems so it never hurts to eliminate them first.
One last thing to try is to go to the printer itself and see if you can print directly from the machine, I’m not familiar with Kyocera but my old Epson sometimes needed a nudge. As it’s possible the job is trapped in the print spooler.

the printer itself and see if you can print directly from the machine
you mean withouth my laptop … it works yes

my Kyocera have epson driver support throught its hardware too :joy:

OK, we’ve eliminated the computer and the driver from being the problem. They’re working fine, your printer is getting the information just not doing its job.

Now that you have cleared the spooler, try turning the printer off and wait about 30 - 40 seconds before turning it back on. The time is more than necessary, but it’s best to make sure everything clears from memory. Next check that the settings on the printer are correct.

Without being there to tech the machine personally, the only thing from here that I can recommend is to go to Keyocera’s website and see if they have a solution.

i will try now

Good luck!


I will be experimenting in Ubuntu