Cuda-12.3.1-1 Signature not accepted

Resolving dependencies…
Checking inter-conflicts…
Download of cuda (12.3.1-1) started
Download of cuda (12.3.1-1) finished
Checking keyring…
Checking integrity…
Error: cuda: signature from “Sven-Hendrik Haase” is invalid
Removing invalid files and retrying…

I already deleted and re-initiated the keyring in pacman.d to no avail.

Have you tried:

sudo rm -f /var/lib/pacman/sync/*
sudo pacman-mirrors --continent
sudo pacman -Syyu

Unfortunately, the Austrian mirror still is on top of the mirrorlist now (I already tried a German mirror) but the certificate still is invalid :frowning:

Trying another:

Packages (1) cuda-12.3.1-1

Total Download Size:    541,53 MiB
Total Installed Size:  4476,28 MiB
Net Upgrade Size:        23,17 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
--2023-12-15 18:21:54--
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving ( 2001:718:1007:48::1:60,
Connecting to (|2001:718:1007:48::1:60|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 567836381 (542M) [application/x-tar]
Saving to: '/var/cache/pacman/pkg/cuda-12.3.1-1-x86_64.pkg.tar.zst.part'

/var/cache/pacman/pkg/cuda-12.3.1-1-x 100%[=======================================================================>] 541,53M  29,0MB/s    in 22s

2023-12-15 18:22:16 (24,3 MB/s) - '/var/cache/pacman/pkg/cuda-12.3.1-1-x86_64.pkg.tar.zst.part' saved [567836381/567836381]

(1/1) checking keys in keyring                                                             [----------------------------------------------------] 100%
(1/1) checking package integrity                                                           [----------------------------------------------------] 100%
error: cuda: signature from "Sven-Hendrik Haase <>" is invalid
:: File /var/cache/pacman/pkg/cuda-12.3.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

Am I the only one affected?

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Arch linux:

$ pacman -Si cuda
Download Size  : 1519.10 MiB
Installed Size : 4476.28 MiB

This seems similar to this earlier thread about a related cuda package

1 Like

Thanks :slight_smile:
Well, my manjaro has two packages: cuda (without the tensorflow-addon) and cuda-tools, which downloads and installs flawlessly.
Btw. I was able to get around that block by using “downgrade” utility, downloading every instance of cuda since 12.3.0-7 up to 12.3.1-2 - which all installed without throwing errors.