CSGO wont launch after the latest update

CSGO won’t launch after the latest stable update 09.02.2021 update
Counter-Strike Global Offensive/csgo.sh: line 88: 4750 Segmentation fault (core dumped) ${DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

Sorry for the misinformation below, doesn’t work.

Putting -windowed in Launch options seems to fix it. So most likely the issue is with the Fullscreen from Mesa/AMD update.

I have the same error, I did the same thing you said to solve the game error but it didn’t work.

Same problem here, -windowed does not help. For me works to restart the machine, sometimes twice and then it launches.

Yes, sorry for the false alarm. It has no real workaround/solution. It just works if you try many times (like 1 in 30).
For further updates, visit Github issue.

I am also facing the same issue … any solution will be appreciated .

I kinda found a fix for it, if u delete the cfg and scripts folder, verify file integrity and launch, it will launch without any issues.

I can’t pinpoint the exact files, and you have to repeat this process every single time but it works.

I got a new SSD 2 weeks ago, since the old one was dying. I reinstalled Manjaro and the problem is gone. I already opened it more than 50 times, each time it worked.

Add -nojoy inicialization parameter.

Hi, your neighbour from debian world. ‘-nojoy’ parameter works and fixes it.

How about the new CSGO updates?