CSGO not running properly

I installed csgo clicked the play button which started it in opengl I am able to interact with the game i can hear the sound when i click any button in the game but nothing is visible its black screen at first with sound when I switch between application the application is there but i can still interact with the game any solution to this?
Thank you in advance!

I’ve seen this issue mentioned multiple times in both /r/linux_gaming and Steam discussions.

One solution I heard someone did was to just use the flatpak version of Steam to play CSGO, don’t know if it worked for everyone though.

Another solution was to use the -nojoy launch option.

1 Like

how do I do this?

Right click the game in Steam Library, and put -nojoy in Launch Options

okay thanx i tried running it in flatpak but it’s crashing on the loading screen so i’ll try this one too.

I tried that the logo appeared nothing after that, tried the flatpak version it did start the game but when i tried playing a match it crashed all the times, the match didn’t start it was stuck on the loading screen.