Cs:Go Contrast and performance problems

kde
nvidia
#1

Hello. I am having very strange performance problems with Csgo and only Csgo.

Specks: Latest Nvidia nonfree driver. Zotac 1070 mini, Ryzen 1700x Manjaro KDE

When I start CS:GO It bumps the contrast or gamma up to 11.


See how the text is weird in the game and the second monitor is all over saturated or something.
This happens only when CS:GO is in focus. So if I alt+tab it goes away.

Here are my launch options (although I do not believe that they are to blame)
Launch options: +exec autoexec -novid -refresh 144 -high -w 1920 -h 1080 -nojoy +fps_max 144 +fps_max_menu 144

I am also encountering some stutters and framedrops. Although I think that might be another issue.

Any and all help very much appreciated.

#2

I see now that the image I provided does not show the problem for some reason... idk why ... just trust me its there ...

#3

That means it's a display/driver setting, e.g. you set up a per-application profile which alters the gamma settings. Maybe you added that to lighten dark areas?

1 Like
#4

I have not touched any settings regarding gamma or anything related to that. The only settings i have touched are tearfree true and tripplebuffer true.

I have no application based settings.

#5

What do you mean by "tearfree"?
I'm not aware of any such option on nvidia non-free.

Also, did you try without any launch options?

#6

It is an option that I found while trying to get rid of tearing in firefox mainly. I have tried with and without it and it is not the problem. Not sure it helps with tearing though

And yes I have tried with and without launch options.

#7

Try this:

It won't matter that it's AMD, don't worry.

#8

Another interesting discovery. Widgets on the desktop go away while the game is in focus and then come back when its not.

Same problem still persists ... hmmm

#9

SOLVED. Somehow the brightness setting in csgo was set to max at default and that also affects the second monitor for some reason... so yea... I an not believe that that was it.

Now I just need to get G-sync working and I will be golde :smiley:

1 Like
#10

:man_facepalming:

#11

Yea I feel stupid.... sorry. But it is weird that the autoexec has this affect on manjaro but not on windows