Creating virtual machine fails because of QEMU

Hello, I just finally got GPU pass-through to be available with “lspci -nnk correctly” but now I’m trying to follow many guides like this, and they want me to pass "something to nvram in the qemu conf file but I have nothing like that, since I can’t seem to post images, let me show you the cd output

[jamesbuild1 ~]# cd /usr/share/ovmf/x64
[jamesbuild1 x64]# ls

So I don’t have anything like what they want me to put in their example

nvram = ["/usr/share/ovmf/ovmf_code_x64.bin:/usr/share/ovmf/ovmf_vars_x64.bin"]

So I’ve put in this thinking that’d get the job done

nvram = ["/usr/share/ovmf/ovmf_code_x64.bin:/usr/share/ovmf/ovmf_vars_x64.bin"]

It might be correct, but when I click begin installation on virt manager having been able to follow the rest of that guide above, I get this

Unable to complete install: ‘internal error: qemu unexpectedly closed the monitor’
Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/”, line 65, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/”, line 2001, in _do_async_install
installer.start_install(guest, meter=meter)
File “/usr/share/virt-manager/virtinst/install/”, line 691, in start_install
domain = self._create_guest(
File “/usr/share/virt-manager/virtinst/install/”, line 639, in _create_guest
domain = self.conn.createXML(install_xml or final_xml, 0)
File “/usr/lib/python3.8/site-packages/”, line 4035, in createXML
if ret is None:raise libvirtError(‘virDomainCreateXML() failed’, conn=self)
libvirt.libvirtError: internal error: qemu unexpectedly closed the monitor

One solution I found online for others was to set myself as a user in the conf file which I tried and that didn’t fix it, what gives!

I’ve since changed nvram to below, which didn’t fix it

nvram = ["/usr/share/ovmf/x64/OVMF_CODE.fd:/usr/share/ovmf/x64/OVMF_VARS.fd"]

Some other info that seems it could help
it’s listing each xml of the tab I have selected on the left, so memory, cpus, etc, I’ll list the one for QEMU I guess, which I think is Overview where I’m trying to setup the firmware:

It’s not wanting to print right to the forum

Here’s the other info:
There are no folders in log for libvirt:

[jamesbuild1 james]# cd /var/log/

[jamesbuild1 log]# ls

audit btmp btmp.1 cups faillog gssproxy journal lastlog libvirt old pacman.log private samba swtpm timeshift vmware vmware-installer vnetlib wtmp Xorg.0.log Xorg.0.log.old

Do you want me to paste the basic qemu.conf file, it’s a mountain of text that I’m willing to post but idk if it’s worth it

Install edk2-ovmf

and change the nvram section in qemu.conf to

nvram = [

restart the libvirtd.service

So idk if I fixed it or if you did, but I think you did, but now the guest runs, but only in a windowed mode, when I switch inputs I’m just seeing a firmware based page that starts immediately when I boot the machine, but the guest is actually displaying stuff, just not to that input, I think it has to do with this?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.