Crashes when using VirtualBox but can't figure out why

Hi,
I am using VirtualBox 6.1 with two centos 7 vms. I use two terminal consoles and ssh to communicate with them. At a random moment, manjaro crashes (I have a black screen a prompt and the only thing I can do is to press Ctrl + Alt + Del and it reboots) and I don’t know why. The thing is that in the journalctl I don’t know what to look for and it is huge. Can somebody help me or can you indicate me the command that could better filter the useful messages?

My config:

inxi -F                                                                                                                                                                                            
System:    Host: manjaro Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 Desktop: GNOME 40.3 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: B450 I AORUS PRO WIFI v: N/A serial: <superuser required> 
           Mobo: Gigabyte model: B450 I AORUS PRO WIFI-CF v: x.x serial: <superuser required> UEFI: American Megatrends v: F51 
           date: 07/29/2020 
CPU:       Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache: L2: 4 MiB 
           Speed: 2291 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2291 2: 2137 3: 2057 4: 2164 5: 2792 6: 1855 7: 1860 
           8: 1869 9: 2052 10: 4094 11: 2795 12: 1866 13: 1861 14: 1943 15: 3590 16: 2053 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 14 [Radeon RX 5500/5500M / Pro 5500M] driver: amdgpu v: kernel 
           Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
           Display: wayland server: X.org 1.20.11 driver: loaded: amdgpu note: n/a (using device driver) - try sudo/root 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Radeon RX 5500 XT (NAVI14 DRM 3.40.0 5.12.19-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.1.5 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
           Device-3: Razer USA Kraken Tournament Edition type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Device-4: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
           Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
           Sound Server-3: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp7s0 state: down mac: 4a:6d:60:67:a6:d3 
           Device-2: Intel I211 Gigabit Network driver: igb 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: 18:c0:4d:2d:6e:d9 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Bluetooth: Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
           Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 1.01 TiB used: 318.12 GiB (30.9%) 
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 447.13 GiB 
           ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
           ID-3: /dev/sdb type: USB vendor: Corsair model: Corsair Voyager SliderX2 size: 118 GiB 
Partition: ID-1: / size: 404.85 GiB used: 303.39 GiB (74.9%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot/efi size: 299.4 MiB used: 476 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 34.51 GiB used: 0 KiB (0.0%) dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 46.8 C mobo: N/A gpu: amdgpu temp: 36.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 418 Uptime: 26m Memory: 31.37 GiB used: 5.94 GiB (18.9%) Shell: Zsh inxi: 3.3.06 

The journal:
I used journalctl. But it is too lengthy, how can I narrow my research? I have an approximated idea of the time of the crash but it is not enough to reduce the length. I might have given not enough logs, I will try to give more logs next time.

Here are the pastebins of the journal:

What I have tried:
On the two VMs that I created I reduced the number of cores from 4 to 2 for each VM (I have 8 cores on my physical CPU). I increased the video memory from 32 to 64 MB for each VM and 4096 MB of RAM for each. I have checked the Enable Nested VT-x/AMD-V. So far it seems to be stable but I would like to understand what was the problem via the logs.

Thank you.

2 minutes of log doesn’t seem to be that large. You could use a service like Pastebin to share the content of the file.

Done, I have updated my post. Is there enough information about the problem I am looking for?

After conducting a Memtest86 test on my RAM, it revealed that I have a corrupted RAM. After changing RAM it seems that all my bugs went away. So my problem seems to be solved.
Thanks anyway.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.