Crash on boot

Occasionally, happened today again the system crashed on boot. I had to do a SysRq-REISUB to reboot. It looks like the system boot but the screen stays black.

$ journalctl -p 3 --since=today
-- Logs begin at Sat 2019-10-12 18:31:36 PDT, end at Tue 2019-10-22 21:26:25 PDT. --
Oct 22 18:03:42 ethelbert kernel: [drm:resource_construct [amdgpu]] *ERROR* DC: unexpected audio fuse!
Oct 22 18:03:52 ethelbert kernel: [drm:atom_op_jump [amdgpu]] *ERROR* atombios stuck in loop for more than 5secs aborting
Oct 22 18:03:52 ethelbert kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing DB88 (len 588, WS 0, PS 8) @ 0xDD8F
Oct 22 18:03:52 ethelbert kernel: [drm:amdgpu_atom_execute_table_locked [amdgpu]] *ERROR* atombios stuck executing B5DC (len 391, WS 0, PS 0) @ 0xB734
-- Reboot --
Oct 22 19:00:57 ethelbert kdeinit5[3643]: inotify_add_watch(/home/lost+found) failed: (Permission denied)
Oct 22 19:00:59 ethelbert kdeinit5[3643]: inotify_add_watch(/lost+found) failed: (Permission denied)
Oct 22 19:00:59 ethelbert kdeinit5[3643]: inotify_add_watch(/root) failed: (Permission denied)
Oct 22 19:01:00 ethelbert kdeinit5[3643]: inotify_add_watch(/boot/lost+found) failed: (Permission denied)
Oct 22 21:04:14 ethelbert kdeinit5[4574]: inotify_add_watch(/home/lost+found) failed: (Permission denied)
Oct 22 21:04:15 ethelbert kdeinit5[4574]: inotify_add_watch(/lost+found) failed: (Permission denied)
Oct 22 21:04:15 ethelbert kdeinit5[4574]: inotify_add_watch(/root) failed: (Permission denied)
Oct 22 21:04:16 ethelbert kdeinit5[4574]: inotify_add_watch(/etc/sudoers.d) failed: (Permission denied)

and

$ inxi -GxxSaNz
System:    Host: ethelbert Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/vmlinuz-5.3-x86_64 root=UUID=e62ad35a-a89e-4f5a-b800-e2950d26a07b rw quiet apparmor=1 
           security=apparmor resume=UUID=377d4364-f136-475d-a02c-dbade01a6230 udev.log_priority=3 ipv6.disable=1 
           sysrq_always_enabled=1 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting,radeon alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.33.0 5.3.6-1-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.2.1 
           direct render: Yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus ID: 04:00.0 chip ID: 10ec:8168 

and

$  qdbus org.kde.KWin /KWin supportInformation
KWin Support Information:
The following information should be used when requesting support on e.g. https://forum.kde.org.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like https://paste.kde.org instead of pasting into support threads.

==========================

Version
=======
KWin version: 5.16.5
Qt Version: 5.13.1
Qt compile version: 5.13.1
XCB compile version: 1.13.1

Operation Mode: X11 only

Build Options
=============
KWIN_BUILD_DECORATIONS: yes
KWIN_BUILD_TABBOX: yes
KWIN_BUILD_ACTIVITIES: yes
HAVE_DRM: yes
HAVE_GBM: yes
HAVE_EGL_STREAMS: yes
HAVE_X11_XCB: yes
HAVE_EPOXY_GLX: yes
HAVE_WAYLAND_EGL: yes

X11
===
Vendor: The X.Org Foundation
Vendor Release: 12005000
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Decoration
==========
Plugin: org.kde.breeze
Theme: 
Blur: 0
onAllDesktopsAvailable: true
alphaChannelSupported: false
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 0, 2
decorationButtonsRight: 6, 3, 4, 5
borderSize: 3
gridUnit: 12
font: Noto Sans Medium,12,-1,5,57,0,0,0,0,0,Regular
smallSpacing: 3
largeSpacing: 12

Platform
==========
Name: KWin::X11StandalonePlatform

Options
=======
focusPolicy: 0
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
legacyFullscreenSupport: false
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 30
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 30
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 31
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777251
showGeometryTip: true
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
inactiveTabsSkipTaskbar: false
autogroupSimilarWindows: false
autogroupInForeground: true
compositingMode: 1
useCompositing: false
compositingInitialized: false
hiddenPreviews: 1
glSmoothScale: 2
xrenderSmoothScale: false
maxFpsInterval: 16666666
refreshRate: 0
vBlankTime: 6000000
glStrictBinding: true
glStrictBindingFollowsDriver: true
glCoreProfile: false
glPreferBufferSwap: 97
glPlatformInterface: 1
windowsBlockCompositing: true

Screen Edges
============
desktopSwitching: false
desktopSwitchingMovingClients: false
cursorPushBackDistance: 1x1
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Screens
=======
Multi-Head: no
Active screen follows mouse:  no
Number of Screens: 2

Screen 0:
---------
Name: DisplayPort-1
Geometry: 0,0,1920x1080
Scale: 1
Refresh Rate: 60

Screen 1:
---------
Name: DisplayPort-2
Geometry: 1920,0,1920x1080
Scale: 1
Refresh Rate: 60


Compositing
===========
Compositing is not active

Anything else I should provide?

Thanks

Update system firmware?

fsck device?


Try booting the fallback kernel.
If it succeeds, recreate kernel images and grub.
Anyway you should verify disks as suggested.

amdgpu FAILED: ati

Update system firmware?

My graphic card is a RX570, it should not even try to load ATI:

Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 01:00.0 
           chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati 
           unloaded: modesetting,radeon alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: 
           renderer: Radeon RX 570 Series (POLARIS10 DRM 3.33.0 5.3.6-1-MANJARO LLVM 9.0.0) 

inotify_add_watch(/root) failed: (Permission denied

fsck device?

Today I get:

$ journalctl -p 3 --since=today               
-- Logs begin at Sat 2019-10-12 18:31:36 PDT, end at Wed 2019-10-23 06:46:35 PDT. --
-- No entries --

I did NOT run fsck (yet), I'll try it tonight

My CPU is an older AMD FX8350

CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer 
           family: 15 (21) model-id: 2 stepping: N/A microcode: 6000852 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 64028 
           Speed: 1476 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 1476 2: 1508 3: 1413 
           4: 1409 5: 1401 6: 1946 7: 2808 8: 3121 

How would I update the firmware? Doesn't it comes from Manjaro/Archlinux?

$ pacman -Q amd-ucode
amd-ucode 20190926.c0590d8-1

Thanks

No - your firmware comes from the manufacturer of your base system.

inxi -M

When your system does that - it is often a graphical issue.

Have you tried booting your system using a live ISO?

I'm on the latest BIOS according to the MSI website

No, I've not tried a live iso lately. The problem is that's very intermittent. As soon as I reboot, it works again

Thanks

Would you define more precisely on which phase of the boot it happens?
Right after grub, during systemd initializing, before SDDM, etc...

Try to test if it prefers cold or warm boot.

Not sure.

  1. enable router (external)
  2. Turn on screens
  3. Power on of the desktop
  4. The BIOS displays with the physical hardware (cpu, ram...)
  5. The screen goes black and I do not see grub unless I press the ESC key

depending on I don't know what, the screen will either stay black or goes into the login screen (I think that's call sddm)

If the screen stays black, I will usually wait for a couple of minutes (according to the clock on my desk), then do Alt-SysRq-reisub, to do a reboot, then it will boot without problem.

If it happens, it's always a cold boot, but it happens between 1 in 4 or 1 in 5 times

Thanks

1 Like

Forum kindly sponsored by