Crash apps like VLC

for 2 weeks I don’t understand but I have applications that I can no longer open. vlc opens in the taskbar at the bottom of the screen but nothing opens. I tried to remove and install these applications but it doesn’t work.

Apps i can’t open VLC MPV

That’s very little information to work with but I’ll try anyways. VLC on Linux is actually not very stable. However, can you post the output if you try to open VLC from a Terminal?

VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[0000562ac696b550] main libvlc: Lancement de vlc avec l'interface par défaut. Utiliser « cvlc » pour démarrer VLC sans interface.
[0000562ac6a14db0] main playlist: playlist is empty

works !

for MPV

mpv: error while loading shared libraries: cannot open shared object file: No such file or directory

i uninstall and install with flatpak and it’s working now

There used to be a bug - when playing videos, not when opening though. And only VLC…
vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.

That isn’t necessarily a valid appraisal. In some cases VLC may need to be tweaked for a given environment;- graphic stack, compositor, display, etc., however, to say it’s not stable on Linux is subjective, at best.

The only annoyances I ever had with VLC were invariably on older, lower performance machines (VLC can be quite resource-hungry at times).

Regarding MPV – The error looks like the same reported with the older library. It seems like nobody is assigned to fix that yet:

You might like smplayer which includes mpv. Install it directly from the repository:

sudo pacman -S smplayer smplayer-skins

There is also an optional skin/theme pack if you don’t care for the default look; and a few extra addons available via the AUR.

Not a solution, but a workaround for sure. Glad it works for you. Cheers.

There are several possible explanations for this, the most likely is that you’re in a partial update state (which is unsupported).

# this will fix a partial update,
# missing dependency (glslang),
# or a deleted file (
sudo pacman -Syu glslang
1 Like