Cracking sound from audio

There’s a constant crackling sound coming from the audio. Both the speakers and headphones do not work, they both have the same crackling sound.

I tried turning off timer-based scheduling based on the official troubleshooting guidelines and also this post on the archived forum. However, it did not fix my issue.

I tried restarting the laptop, modifying alsa-base.conf, and even adding a boot parameter. However, none of them fixed my issue and I still get the crackling sound.

The sound was working perfectly until all of a sudden it just stopped. Literally nothing happened, I did not turn off the device, I did not update my laptop, essentially, I did nothing and it just stopped out of the blue.

I would really appreciate some help on resolving this situation. Thank you for your kind help and support! :blush:

Please see: :wink:

Thank you for guiding me to the right resources for providing relevant outputs @TriMoon! Please find them mentioned below.

$ inxi -Fazy
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=e1cec159-110f-43a7-809a-d6aa6cf36829 rw intel_pstate=disable 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Predator PH317-53 v: V1.04 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: CFL model: Alphard_CFS v: V1.04 serial: <filter> UEFI: Insyde v: 1.04 
  date: 06/19/2019 
  ID-1: BAT0 charge: 42.4 Wh condition: 42.4/42.4 Wh (100%) volts: 16.4/15.4 
  model: SMP KT00407009 AP18E7M type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_3 model: Logitech Wireless Mouse MX Master 3 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 1214 MHz min/max: 800/2600 MHz boost: enabled Core speeds (MHz): 
  1: 1274 2: 1021 3: 1345 4: 1271 5: 1311 6: 1181 7: 1299 8: 1286 9: 1328 
  10: 1279 11: 1269 12: 1837 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] 
  vendor: Acer Incorporated ALI driver: nvidia v: 450.66 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:2191 
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 1-7:2 
  chip ID: 04f2:b64f serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4") 
  s-diag: 748mm (29.4") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128 
  size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
  OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000 
  bus ID: 07:00.0 chip ID: 1969:e0b1 
  IF: enp7s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: iwlwifi 
  v: kernel port: 3000 bus ID: 08:00.0 chip ID: 8086:2723 
  IF: wlp8s0 state: up mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
  Local Storage: total: 1.14 TiB used: 478.44 GiB (40.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN720 SDAPNTW-256G-1014 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 10121000 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: ACM1 scheme: GPT 
  ID-1: / raw size: 221.11 GiB size: 216.64 GiB (97.98%) 
  used: 186.40 GiB (86.0%) fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 53.0 C mobo: N/A gpu: nvidia temp: 40 C 
  Fan Speeds (RPM): N/A 
  Processes: 311 Uptime: 3h 01m Memory: 15.49 GiB used: 4.22 GiB (27.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 8/9 Packages: pacman: 1516 
  lib: 433 flatpak: 0 Shell: Zsh v: 5.8 running in: konsole inxi: 3.1.05 
$ ls /var/log/
audit  btmp  btmp.1  Calamares.log  cups  faillog  gssproxy  gufw.log  journal  lastlog  old  pacman.log  private  samba  tallylog  wtmp  wtmp.1  Xorg.0.log  Xorg.0.log.old  Xorg.1.log  Xorg.1.log.old

Since the output of dmesg is huge, I’ve uploaded it to pastebin.

Please let me know for any other outputs that might help in debugging or solving this issue!