CPU Throttling while gaming on a HP Pavillion 15-cb010nu

While attempting run to relatively high load games, the CPU of my laptop is severely throttled to the point of running a whole GHz short of what it normally does. I’ve only observed this when gaming, but that’s the only high load applications I run on this device.
My inxi output:

  Kernel: 5.13.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=aa563829-0d1e-465c-8f93-296f552562c6 rw acpi_osi=! 
  "acpi_osi=Windows 2020" quiet apparmor=1 security=apparmor 
  udev.log_priority=3 thermal.nocrt=1 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: HP product: HP Pavilion Power Laptop 15-cb0xx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 836B v: 46.24 serial: <filter> UEFI: Insyde v: F.41 
  date: 12/01/2020 
  ID-1: BAT0 charge: 58.2 Wh (100.0%) condition: 58.2/58.2 Wh (100.0%) 
  volts: 17.2 min: 15.4 model: HP Primary type: Li-ion serial: N/A 
  status: Full 
  RAM: total: 15.52 GiB used: 5.15 GiB (33.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  cache: L2: 6 MiB bogomips: 20004 
  Speed: 2452 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 2452 2: 2495 
  3: 2365 4: 2458 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c8d class-ID: 0300 
  Device-3: Realtek HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus-ID: 1-4:3 chip-ID: 0bda:58eb class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") 
  s-diag: 1052mm (41.4") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 96 
  size: 509x286mm (20.0x11.3") diag: 584mm (23") 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.1.6 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
  Device-2: SteelSeries ApS SteelSeries Arctis 1 Wireless type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.5:7 chip-ID: 1038:12d0 
  class-ID: 0300 
  Device-3: JMTek LLC. USB PnP Audio Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.6:8 chip-ID: 0c76:161e 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.13.8-1-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.19 running: no 
  Sound Server-4: PulseAudio v: 15.0 running: yes 
  Sound Server-5: PipeWire v: 0.3.33 running: yes 
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 
  bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 05:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-7:5 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 1.03 TiB used: 278.13 GiB (26.3%) 
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SD8GB size: 7.64 GiB block-size: 
  physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: MBR 
  SMART Message: Unknown smartctl error. Unable to generate data. 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: LITE-ON model: CA1-8D128-HP 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: A182 temp: 47.9 C scheme: GPT 
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: RXM3 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 101.87 GiB size: 99.71 GiB (97.88%) 
  used: 25.87 GiB (25.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: aa563829-0d1e-465c-8f93-296f552562c6 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: 3B9E-2E4B 
  ID-3: /home/<filter>/hdd raw-size: 931.51 GiB size: 915.82 GiB (98.31%) 
  used: 252.25 GiB (27.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 85edc2b6-3629-4ebe-9e02-9bb31b61f4bd 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: a37726db-810f-4b73-aa2d-555275657512 
  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 6.7 GiB fs: vfat label: EMUNAND9SD 
  uuid: 4641-0000 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-3:2 info: HP LP2475w Monitor Hub ports: 6 rev: 2.0 speed: 480 Mb/s 
  power: 2mA chip-ID: 03f0:2f24 class-ID: 0900 
  Device-1: 1-3.2:4 info: Valve Wireless Steam Controller type: Keyboard,HID 
  driver: hid-steam,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 28de:1142 class-ID: 0300 
  Hub-3: 1-3.4:6 info: Microchip (formerly SMSC) USB 2.0 Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s power: 2mA chip-ID: 0424:2514 class-ID: 0900 
  Device-1: 1-3.4.3:9 info: Razer USA BlackWidow Lite (2018) 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s power: 500mA chip-ID: 1532:0235 class-ID: 0300 
  Device-2: 1-3.4.4:10 info: Razer USA Razer Naga Pro type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 1532:0090 class-ID: 0300 serial: <filter> 
  Device-3: 1-3.5:7 info: SteelSeries ApS SteelSeries Arctis 1 Wireless 
  type: Audio,HID driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 
  rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 1038:12d0 class-ID: 0300 
  Device-4: 1-3.6:8 info: JMTek LLC. USB PnP Audio Device type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 0c76:161e class-ID: 0300 
  Device-5: 1-4:3 info: Realtek HP Wide Vision HD Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0bda:58eb class-ID: 0e02 serial: <filter> 
  Device-6: 1-7:5 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-4: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 69.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 251 Uptime: 9m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1295 pacman: 1288 lib: 356 flatpak: 0 
  snap: 7 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.06 

What I’ve observed: A short while after starting the game, the CPU which normally runs at about 3.2GHz will throttle down to 2.2GHz incurring a significant hit to performance resulting in intermittent stuttering and low FPS. I’ve tested this with several games including FFXIV, Trails of Cold Steel 3 and Guilty Gear Strive.
What I’ve tried to no effect:
-setting the governor to “performance”
-disabling and removing TLP
-setting thermal.nocrt=1 in the kernel arguments
-updating the kernel to 5.13 from 5.10
-setting the ACPI OSI to “Windows 2020”(I did get a slightly faster boot time though, so yay)

I suspect this may be a thermal issue, as I’m not hearing the fans spin up under load the same way they used to under Windows and because the cpu frequency observed in cpupower-gui slowly returns to the expected 3.2GHz when idle. fancontrol doesn’t appear to be able to detect the fans, so I can’t properly verify anything objective other than they’re running, which I suspect is a byproduct of HP’s design for the thing since I wasn’t able to get any good info from the fans with similar utilities on Windows.

Any idea how I can further diagnose/troubleshoot this? Are there any sort of HP laptop specific fixes I need to apply?

what temperatures are “sensors” output when playing?

Around 70C.

Adapter: ISA adapter
Package id 0:  +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +71.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +68.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +63.5°C  

Adapter: PCI adapter
Composite:    +53.9°C  (low  = -273.1°C, high = +84.8°C)
                       (crit = +94.8°C)
Sensor 1:     +53.9°C  (low  = -273.1°C, high = +65261.8°C)

Adapter: Virtual device
temp1:        +58.0°C  

Adapter: ACPI interface
in0:          17.16 V  
curr1:         0.00 A  

Adapter: ACPI interface
temp1:        +73.0°C  

On a side note, I did try NBCF but to no avail, as it turns out it can’t control the fans while optimus is enabled, which is always since I have an external monitor hooked up. Then again, I’m not entirely sure if fans or thermal in general is the problem.

Check BIOS for thermal management, usually it has a temperature setting when a throttling must be done. But if not, then you’re out of luck, it’s simply hardware managed that you have no control of.

Figures. Only setting is a “Fan Always On” toggle. Which is a lie, since there’s two fans, and apparently the second one doesn’t kick in till 70C, regardless of that toggle, which is roughly where the throttle point is. Good jerb, HP.
Moral of this story is stay the hell away from HP laptops if you wanna play games on linux I suppose.

Fixed it for you :stuck_out_tongue:

1 Like

I learned it the hard way as well, you’re not alone. I’ve been with Asus ROG for the last 3 years and it’s still running strong.