CPU limited to 800 Mhz when is running without battery

Hello! I’m having a small issue with my laptop. When I remove the charger it runs up to 800 Mhz, I would like to increase this frequency however I don’t know how.

Here’s my inxi -Fza

 Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
 parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
 root=UUID=759c5942-a42f-4370-bfe8-fa4cfa3281e8 rw quiet splash apparmor=1 
 security=apparmor resume=UUID=781fe0ae-7244-4c2d-b4e0-3ef218bf3d2a 
 Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
 Distro: Manjaro Linux base: Arch Linux 
 Type: Laptop System: LENOVO product: 81UH v: Lenovo Legion Y740-15IRHg 
 serial: <filter> Chassis: type: 10 v: Lenovo Legion Y740-15IRHg 
 serial: <filter> 
 Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter> 
 UEFI-[Legacy]: LENOVO v: BVCN11WW(V1.07) date: 07/04/2019 
 ID-1: BAT1 charge: 31.9 Wh (77.4%) condition: 41.2/57.4 Wh (71.8%) 
 volts: 12.4 min: 11.6 model: Celxpert L17C3PG2 type: Li-ion 
 serial: <filter> status: Charging 
 Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
 arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
 microcode: DE cache: L2: 12 MiB 
 flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
 bogomips: 62431 
 Speed: 4385 MHz min/max: 1692/4500 MHz Core speeds (MHz): 1: 4385 2: 4345 
 3: 4392 4: 4399 5: 4304 6: 4317 7: 4349 8: 4401 9: 4379 10: 4371 11: 4400 
 12: 4398 
 Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
 Type: l1tf 
 mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
 Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
 Type: meltdown mitigation: PTI 
 Type: spec_store_bypass 
 mitigation: Speculative Store Bypass disabled via prctl and seccomp 
 Type: spectre_v1 
 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
 Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
 IBRS_FW, STIBP: conditional, RSB filling 
 Type: srbds mitigation: Microcode 
 Type: tsx_async_abort status: Not affected 
 Device-1: NVIDIA TU106BM [GeForce RTX 2060 Mobile] vendor: Lenovo 
 driver: nvidia v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
 chip-ID: 10de:1f51 class-ID: 0300 
 Device-2: Chicony Integrated Camera (1280x720@30) type: USB 
 driver: uvcvideo bus-ID: 1-7:4 chip-ID: 04f2:b604 class-ID: 0e02 
 serial: <filter> 
 Display: x11 server: X.org 1.20.11 compositor: gnome-shell driver: 
 loaded: nvidia resolution: <missing: xdpyinfo> 
 OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
 direct render: Yes 
 Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
 v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 
 chip-ID: 8086:a348 class-ID: 0403 
 Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo 
 driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 
 class-ID: 0403 
 Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
 Sound Server-2: JACK v: 0.125.0 running: no 
 Sound Server-3: PulseAudio v: 14.2 running: yes 
 Sound Server-4: PipeWire v: 0.3.26 running: yes 
 Device-1: Intel Wireless-AC 9560 [Jefferson Peak] 
 vendor: Rivet Networks Killer driver: iwlwifi v: kernel bus-ID: 00:14.3 
 chip-ID: 8086:a370 class-ID: 0280 
 IF: wlp0s20f3 state: up mac: <filter> 
 Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
 vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 3f:00.0 
 chip-ID: 10ec:8168 class-ID: 0200 
 IF: enp63s0 state: down mac: <filter> 
 IF-ID-1: br-3f3ff8afd4bd state: down mac: <filter> 
 IF-ID-2: br-ad25f982d2b0 state: up speed: 10000 Mbps duplex: unknown 
 mac: <filter> 
 IF-ID-3: br-afc1b131f59a state: down mac: <filter> 
 IF-ID-4: br-c630f90ded27 state: down mac: <filter> 
 IF-ID-5: docker0 state: down mac: <filter> 
 IF-ID-6: veth8959124 state: up speed: 10000 Mbps duplex: full 
 mac: <filter> 
 IF-ID-7: veth9413bb4 state: up speed: 10000 Mbps duplex: full 
 mac: <filter> 
 IF-ID-8: vethb692579 state: up speed: 10000 Mbps duplex: full 
 mac: <filter> 
 Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
 driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001 
 Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
 rfk-block: hardware: no software: yes address: see --recommends 
 Local Storage: total: 953.87 GiB used: 154.16 GiB (16.2%) 
 SMART Message: Required tool smartctl not installed. Check --recommends 
 ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
 model: MZVLB1T0HALR-000L2 size: 953.87 GiB block-size: physical: 512 B 
 logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
 rev: 5L1QEXA7 temp: 33.9 C scheme: MBR 
 ID-1: / raw-size: 919.45 GiB size: 904.02 GiB (98.32%) 
 used: 154.16 GiB (17.1%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
 Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
 ID-1: swap-1 type: partition size: 34.41 GiB used: 0 KiB (0.0%) 
 priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2 
 System Temperatures: cpu: 57.0 C mobo: N/A gpu: nvidia temp: 53 C 
 Fan Speeds (RPM): N/A 
 Processes: 348 Uptime: 2h 24m wakeups: 9 Memory: 31.28 GiB 
 used: 4.74 GiB (15.1%) Init: systemd v: 247 tool: systemctl Compilers: 
 gcc: 10.2.0 Packages: 1523 pacman: 1516 lib: 446 flatpak: 0 snap: 7 
 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.04 

And my sudo cpupower frequency-info

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 4.50 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 1.69 GHz and 4.50 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

I’ve tried with cpupower-gui, however, I haven’t been able to modify the frequency

Any help is appreciated

The screenshot and the terminal output both mention 4.5 GHz as max frequency. Are you soure your system is not exceeding 800 Mhz even when put under pressure?

That kernel is EOL - you should switch to a newer one.

How do I switch kernels? According to pacman my system is up to date.

I’m not sure if it’s exceding 800 Mhz but it’s very slow when I unplug the charger

Generally that can be done with the kernel utility in the settings of your chosen DE or in CLI with the mhwd-kernel command. Personally i would recommend going with either 5.4 or 5.10 as those are long term support kernels (LTS) and they should have all the driver support you would need.

The issue you are having might be tlp related.

  • check for "bios"UEFI update
  • can you provide
sudo mhwd-kernel -li