Cpu idle temps to high?

I just installed Manjaro with gnome and my laptop (Lenovo thinkpad X1 extreme v1) is warm (not hot) to the touch at idle. I can’t find a way to bring the idle cpu temps down. I don’t want the laptop warm and I don’t want this to impact my battery.

I really like this distro and would love to keep using it.

CPU: Intel Core i7-8750H
GPU: Nvidia geforce 1050ti max-q (video-hybrid-intel-nvidia-440xx-prime)
Gnome version: 3.36.5

All I’m running right now is Firefox one tab, and gnome terminal.

From sensors:

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +52.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +52.0°C  (high = +100.0°C, crit = +100.0°C)

From tlp-stat -t

— TLP 1.3.1 --------------------------------------------

+++ Temperatures
/proc/acpi/ibm/thermal = 53 50 0 0 0 0 0 0 [°C]
Fan speed (fan1) = 0 [/min]
Fan speed (fan2) = 0 [/min]

From tlp-stat -s

— TLP 1.3.1 --------------------------------------------

+++ System Info
System = LENOVO ThinkPad X1 Extreme
BIOS = N2EET48W (1.30 )
Release = “Manjaro Linux”
Kernel = 5.7.17-2-MANJARO #1 SMP PREEMPT Sat Aug 22 14:58:17 UTC 2020 x86_64
/proc/cmdline = BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=84c26352-4902-4d9d-b649-178038cc0e9e rw quiet apparmor=1 security=apparmor udev.log_priority=3
Init system = systemd
Boot mode = UEFI

+++ TLP Status
State = enabled
RDW state = not installed
Last run = 12:03:05 PM, 1325 sec(s) ago
Mode = battery
Power source = battery

Device temps really depend on your ambient temp, without this data we won’t be able to judge fairly if it’s normal or not (here ambient temp is 30°C, my 7700HQ is idling at 50ish°C as well). However, you can also check what CPU governor your kernel is running and if it’s already powersave you can also check the frequencies. If it’s already running at low frequencies then your cooling system might not be adequate and needs reinforcements. I changed my thermal paste to Kryonaut to reach its current state, this way it never reaches 90°C even if all 4 cores / 8 threads are 100%. But idle temp indeed doesn’t go much lower.

Off topic but…

https://wiki.archlinux.org/index.php/TLP#ThinkPads_only

I think I may have found an issue. The readings I posted originally was when I was on battery and the fans were at 0 rpm. I plugged in the power cord and now the fans have turned on and these are my temps

from sensors when on AC

thinkpad-isa-0000
Adapter: ISA adapter
fan1: 2464 RPM
fan2: 2166 RPM
temp1: +40.0°C
temp2: +36.0°C
temp3: +0.0°C
temp4: +0.0°C
temp5: +0.0°C
temp6: +0.0°C
temp7: +0.0°C
temp8: +0.0°C

coretemp-isa-0000
Adapter: ISA adapter
Package id 0: +40.0°C (high = +100.0°C, crit = +100.0°C)
Core 0: +38.0°C (high = +100.0°C, crit = +100.0°C)
Core 1: +40.0°C (high = +100.0°C, crit = +100.0°C)
Core 2: +38.0°C (high = +100.0°C, crit = +100.0°C)
Core 3: +39.0°C (high = +100.0°C, crit = +100.0°C)
Core 4: +40.0°C (high = +100.0°C, crit = +100.0°C)
Core 5: +38.0°C (high = +100.0°C, crit = +100.0°C)

When on battery my fans don’t seem to be turning on, but on AC they turn on when needed. per the Arch wiki I ran pwmconfig to fix this but this was the output.

pwmconfig

Found the following PWM controls:
hwmon6/pwm1 current value: 255
hwmon6/pwm1 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) y
hwmon6/pwm1_enable stuck to 2
Manual control mode not supported, skipping hwmon6/pwm1.
There are no usable PWM outputs.

How can I make sure my fans are working correctly when on battery?