CPU governor randomly switching to Powersave, thus heavily limiting performance

Good day, everyone. I have a small, low power laptop with a Pentium N3710 processor @ 2.56 GHz. Recently I’ve been facing an issue where the CPU governor changes randomly to Powersave, thus bringing the core clock speed from 2560 MHz to 480 MHz. As you can imagine, this heavily limits performance on an already low end CPU.

I tried cpupower-gui from the AUR (I think) and it failed to make any changes whatsoever. The frequency was locked to 480 MHz, despite manually adjusting it or explicitly setting CPU governor as performance. Only a reboot solves it. I also tried installing the 5.10 LTS kernel, but it only made the problem worse.

I don’t know how to reproduce this bug either. It just happens on its own. Any help would be greatly appreciated. Thank you.

System specifications :
Intel Pentium N3710 @ 2.56 GHz
Manjaro KDE (all updates applied as of writing)
Kernel 4.19 LTS

Welcome here, @syedwafihasan :slightly_smiling_face:

Have you tried to switch the governor to performance as described here:

Isn’t it possible that tlp makes the change?

This is actually the first link I followed, after a quick Google search. None of the methods here worked. It seemed like the CPU locked itself down for some reason. Neither the command line nor the GUI could make the frequency rise up again.

Have you tried other kernels?

I’m not entirely convinced of that, because the issue happens at random, and not after any kind of power input change from AC to battery or vice versa.
Manually setting tlp to AC mode also didn’t help.

Only 4.19 and 5.10.

The issue started after I explicitly installed 5.10, so I naturally assumed that the bug was related to the kernel. But downgrading it back to 4.19 didn’t eradicate the issue. It certainly did make it extremely less frequent, as compared to 5.10, but it is still there.

Try 5.4 & 4.14 as well.

Also in trying to solve it it could be theoretically that you have unwillingly changed some settings which now make it difficult to solve the issue. To find out if this could be an issue you could make a fresh user account and start with fresh settings.

Okay sir (please correct me if I’m wrong). I will install both kernels if the problem resurfaces. Will update as it goes.
Edit : Sorry, didn’t see the user thingy earlier. Will do.

Package cpupower includes a systemd service to set the CPU governor at system boot, but the service is not active on Manjaro and has to be configured for the correct governor

Open the configuration file in a text editor
(other text editors are available, but nano is usually installed on any version of Manjaro)

sudo nano /etc/default/cpupower

add the setting for the performance governor

# Define CPUs governor
# valid governors: ondemand, performance, powersave, conservative, userspace.

Use Ctrl + O to save the file and Ctrl + X to exit nano

Then enable and start the systemd service

systemctl enable --now cpupower.service