CPU Frequency not match

i have AMD Ryzen™ 5 2500U dell laptop but CPU Frequency not match from amd site .
in manjaro - CPU max MHz:2000.0000
CPU min MHz:1600.0000
in amd site - Base Clock 2.0GHz
Max. Boost Clock Up to 3.6GHz
how to change?

No, that is totally correct. It clocks up to 2Ghz and on request, depending on temperature, it boosts up to 3.6Ghz, of course will clock down if temperature is too high.

When running:

inxi -Cazy

your should see:

boost: enabled

A really simple test would this…

Change to ondemand governor:

sudo cpupower frequency-set -g ondemand

Run this in one terminal to watch the frequency:

watch -n.1 "grep \"^[c]pu MHz\" /proc/cpuinfo"

and this in second terminal for a stress-test:

for i in $(seq $(getconf _NPROCESSORS_ONLN)); do yes > /dev/null & done

kill the stress test:

killall yes

It should show 3600 Mhz.

do i need to use last command - killall yes?

It kills/closes the stress test:

another questions is-

watch -n.1 “grep “^[c]pu MHz” /proc/cpuinfo”

after this command then you says in second terminal then i run this command

for i in $(seq $(getconf _NPROCESSORS_ONLN)); do yes > /dev/null & done

in first terminal shows alnost 3GHZ
but last command killall yes
then i run

watch -n.1 “grep “^[c]pu MHz” /proc/cpuinfo”

this command again and show 1800 to 1900
i want set manualy so can i do that i want all time 3.6 gHz

Maybe a GUI is more suitable for you. cpupower-gui should do want you want. Just install it in the package-manager.

However, a boost is not a stable frequency and is just some extra power by temporary “overclocking” which depends on temperature.

It is like drinking red bull and for a short time you are really productive, but after that you will slow down…

i can`t found in pamac package menager

pamac is a package-manager. It is just called pamac.

but i cant found , what i want to say

You can’t find cpupower-gui in pamac?

…sorry was a typo. I forgot the o in power.

i found right now ,ok now what i need to do?

thats i got after open cpupower-gui , and its says 2.0 ghz max but why>?

Set everything to max, what would 2Ghz for you.

It is not possible to set it on 3.6Ghz because it is a boost and managed by the CPU. You can just request a temporary boost.

So lets make it simple: If you run a program and it requests a lot of tasks, then the CPU will boost up as long as the conditions are good.

It is dynamic:
AMD Turbo Core - Wikipedia

Anything unclear?

okay after that. if i do restart then i need to setup again?

I think the turbo boost is disabled in BIOS by default.
You check the setting in BIOS and enable turbo boost.

already tried to find turbo boost but nothing has in my laptop

Manjaro is shipped with TLP by default. At the file: (full path) /etc/tlp.conf you should add/edit:




After a reboot it should work…

But anyway, I don’t understand why you want to run it all the time at max… :man_shrugging:

Btw on battery mode the cpu boost is disabled by default.

That means your laptop can not support the turbo boost, because its fan is weak. :man_shrugging:

/etc/tlp.conf  :heavy_check_mark:  2m 6s 
zsh: permission denied: /etc/tlp.conf
   ~  sudo /etc/tlp.conf  126 ✘
[sudo] password for hello-nahian:
sudo: /etc/tlp.conf: command not found
   ~  sudo su  1 ✘  5s 
[nahian-pc hello-nahian]# /etc/tlp.conf
bash: /etc/tlp.conf: Permission denied

why Permission denied?

amd has turbo boost like intel?