Couldn't find synaptics properties. No synaptics driver loaded?

touchpad

#1

I’m trying to enable palm detection on my ElanTech touchpad to prevent the heel of my palm “clicking” while I’m typing.

I get the following error:

$ synclient PalmDetect=1
Couldn't find synaptics properties. No synaptics driver loaded?

Running syndaemon -d first doesn’t help.

I have a Asus UX330. How do I successfully run synclient?

$ journalctl -k | grep -i elan
Sep 16 15:34:10 svelte kernel: input: ELAN1300:00 04F3:3028 Touchpad as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-6/i2c-ELAN1300:00/0018:04F3:3028.0001/input/input13
Sep 16 15:34:10 svelte kernel: hid-multitouch 0018:04F3:3028.0001: input,hidraw0: I2C HID v1.00 Mouse [ELAN1300:00 04F3:3028] on i2c-ELAN1300:100:
$
$ xinput -list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN1300:00 04F3:3028 Touchpad            id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control               id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                      id=11   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
$ 

#2

Manjaro uses libinput by default and not synaptics driver.

Take a look here:


#3

maybe this can help (for disabling touchpad while typing):

https://bbs.archlinux.org/viewtopic.php?id=215218

with the option
"Disable-w-typing: enabled"


#4

Synaptics has been deprecated in Arch and replace by libinput. You can still install and use it, however. Consult the ArchWiki.


#5

Yeah synaptics is no longer maintained, so you better find an alternative solution. However, it’s still in the repositories and you can install the package xf86-input-synaptics which includes the binary synclient (I also use synaptics for the lxde edition because it’s needed, but if you are using any other edition I wouldn’t recommend it).


#6

@c00ter, I was following the Arch wiki on Synaptics… and I have xf86-input-synaptics installed as @Thanos_Apostolou mentions.

I’d be happy to use libinput if it supported everything that Synaptics did…

I already have:

$ xinput list-props 'ELAN1300:00 04F3:3028 Touchpad' | grep -i disable
        libinput Disable While Typing Enabled (297):    1
        libinput Disable While Typing Enabled Default (298):    1

But I want finer-grained control, eg, man synaptics has:

       Option "PalmDetect" "boolean"
              If palm detection should be enabled.  Note that this also requires
              hardware/firmware support from the touchpad. Property: "Synaptics
              Palm Detection"

       Option "PalmMinWidth" "integer"
              Minimum finger width at which touch is considered a palm.
              Property: "Synaptics Palm Dimensions"

       Option "PalmMinZ" "integer"
              Minimum finger pressure at which touch is considered a palm.
              Property: "Synaptics Palm Dimensions"

I can’t see these options in man libinput. How would I use these settings in libinput?


#7

@Ataraxy, I do not know. Peripheral neuralgia dictates I use my laptop’s touchpad only as a last resort. I always have it set to off, unless the mouse gets unplugged. Personally, I would consult the ArchWiki as suggested and/or search the Arch forums, as I’ve seen posts similar to yours there whereby users wanted much finer-grained control. You don’t want to post there, since you aren’t running Arch, but the information is out there. :smiley:

regards


#8

Just a thought … check if you have /usr/share/X11/xorg.conf.d/10-evdev.conf that points to /etc/X11/xorg.conf.d/10-evdev.conf
Edit that file and comment out the part referring to touchpad. Something like this:

#Section "InputClass"
#        Identifier "evdev touchpad catchall"
#        MatchIsTouchpad "on"
#        MatchDevicePath "/dev/input/event*"
#        Driver "evdev"
#EndSection

The reason i mention it is because for my cintiq tablet i need the xf86-input-wacom installed, even tho the libwacom is installed by default and somehow works, but doesn’t access the settings and mappings of the tablet. So i had to comment out the tablet part from 10-evdev.conf file.
Maybe is the same with libinput and xf86-input-synaptics


#9

The solution was to restart X11 after linking:

/etc/X11/xorg.conf.d/70-synaptics.conf -> /usr/share/X11/xorg.conf.d/70-synaptics.conf