Could someone recommend me a Gnupg that work?

Good day! Hope you well I’m getting over frustrated for the past 2 days to try to make simple tasks working aka PgP!
I used on tails a fantastic Pgp that even a not so good like me after 20 years of microsoft could understand… So i try to get something on kde Manjaro but really what I got was more error messages that I ever seen in my all life at Microsoft so first I tried the good old Kleopatra, first issue were actually straight away I could not create a keys with a Paraphrase… (see pic)

Then I try the good old Kgpg and that wasn’t much better as I could not decrypt any messages and run into a lot of error messages too:
[GNUPG:] ERROR pkdecrypt_failed 83918950
[GNUPG:] ERROR pkdecrypt_failed 83918950

At the end of my frustration I was wondering if any of you would have something simple that reliable and work easy… Normally Kleopatra on W10 isn’t too bad but had no luck here in Linux unfortunately
Thanks!

Hello @hsdredgun :wink:

I think Kgpg uses python-gpg for decrypting. There you need to add

allow-loopback-pinentry

to the file ~/.gnupg/gpg-agent.conf .

OR/AND

use-agent 
pinentry-mode loopback

to this file: ~/.gnupg/gpg.conf

If these files are not there, then create them.

Source: Fixing GPG "Inappropriate ioctl for device" errors — Daniel15

However… seahorse, it is a GTK application, works out-of-the-box for me. Nothing needed to be added, because it is uses gnome-keyring as backend and not python-gpg or pinentry.

1 Like

All I can say is I use kgpg for a long time and never had problems. Make sure you properly add your keys to the database first.

Hello megavolt! Hope you well I also found this solution but unfortunately this did not work at all also the suprising thing is I do not have anything into my folders .gnupg and even after creating those two files I could not decrypt anything…

I m pretty sure it must be me doing something wrong there very frustrating! I’m fairly new to PGP so lets go back to basic, you first create a private keys then send you public keys to you friend or people you want to communicate with then you copy their public keys. After both of us had public keys had to the ring we should be able to communicate privately correct? Everytime I give a try between both of my laptop is not doing anything and pop message of error saying it impossible to decrypt…
Tried everything nothing works

@hsdredgun

Ok i think there is a general problem with gpg on your side. Lets do a simple test on the terminal:

I assume that you have already a private and public key.

  1. List all private keys or public keys:
gpg --list-secret-keys
gpg --list-keys
  1. Encrypt a simple text to a file:
echo "This is my message" | gpg --encrypt --sign --armor --recipient mymail@domain.com > message.asc
  1. Now decyrpt the file:
gpg --decrypt  message.asc

Does it work?

Unfortunately not
Here is the error message

gpg --decrypt message.asc
gpg: decrypt_message failed: Unknown system error

I got 4 private keys for trying I did run some test with my other laptop same issue with both software Kleopatra can’t create any private keys with password and for KGPG impossible to decode any keys… It’s just weird I never had any issue like this before is any change we can delete and restart the gnupg like rebuild it from scratch? ( I m a super noob so may be a stupid question that one…)

This also happend on Kleopatra do you have the same issue???

If that did not work, then there is problem with your gpg config or database in general… One of your apps messed that up.

I installed kleopatra and creating a keypair works flawless. Nothing have to be added at the config.

Maybe it is a permission error? Set it:

chmod -R 700 ~/.gnupg/ 
chown -R $USER:$USER  ~/.gnupg/

Try to rename the folder ~/.gnupg to something else and let gpg recreate everything.

Also, and I say that because you come from windows:

Manjaro is a rolling release!

That means:

:warning: Partial Upgrade = Broken System

Do also a full upgrade:

pamac upgrade --force-refesh

On stable branch you get once every month a big update. Don’t skip it for too long. When installing new software, then also run a full upgrade before.

1 Like

Good news So I found something!!! This don’t work on Kleopatra only kgpg!

First delete the folder ./gnupg and everything! Like delete kleopatra and kgpg!

Then restart the all thing! Install Kgpg and the ./gnupg folder will be create (as you may know) then I create a htlm folder with the name of gpg,conf and I could create a key! With kgpg only tho kleopatra doesn’t work at all!
So I also made a mistake myself I did not realise that with Kgpg you have to sign the imported keys before using it so that worked after I sign it! Good news!
Now the only issue I have with kgpg is I can not delete a test keys tho! I can click and try to delete the keys this doesnt work never even after restarting… I have to go to gnpg and delete everything manually… I’ll try to chomd -R the folder for Kleopatra ! I ll let you know…
It’s quite bizarre that yours works perfectly! I try in both of my laptop and both had issues!

Edit I try to change the Chmod and chown with kleopatra and still have this error message
“Could not create key pair: Inappropriate ioctl for device”

Yes, I was going to point that out.

From here:

If you get an error message saying “Inappropriate ioctl for device”, do this:

  • run export GPG_TTY=$(tty) and/or add that to your ~/.bashrc or ˜/.bash_profile

You can give it a try.

1 Like

Okay we got some move there so I stop having “Inappropriate ioctl for device” after adding export GPG_TTY=$(tty) to both files but now I got this message of error


Could not create key pair no such files or directory look like I need to create a folder for the private keys or something???

Is the folder there?

ls ~/.gnupg/

otherwise run:

gpg

and it will quick recreate that folder.

it’s yes very weird situation do you guys run the latest kernel too??? could it be this?

I believe it has nothing to do with the kernel…

I run the latest LTS KerneL linux 5.10, but not the latest stable one: linux 5.13 :wink:

1 Like

Check if the folder ~\.gnupg\private-keys-v1.d\ exists. If it doesn’t, create it and set right permissions.

mkdir -p ~/.gnupg/private-keys-v1.d
chmod 700 ~/.gnupg/private-keys-v1.d

If this folder does, indeed, exist, try to trace gpg to get which folder isn’t being found.

strace -o /tmp/foo gpg --full-gen-key

(source)

1 Like

Thanks again for your help I really really really appreciate unfortunately this is not working… :sob: I’m about to give up! arghhh

@megavolt found the solution and it’s a weird one:
Installing

anydesk

fix the all issue…
someone will have to explain me that one…
Thanks you again!