Could not install with only 2GiB of RAM

Yes, Manjaro will work on 2GiB of RAM, but I mean Calamares installer. I couldn’t make it work on 2GiB. So good that Manjaro itself will work, but you have no way of install it before upgrading the RAM. :upside_down_face:

Indeed. Manjaro uses Calamares; therefore there’s no reason why the installer should not work.

I advise creating a new #support thread and provide the Calamares logs for further investigation.

I will open an issue on the gitlab. If 2GiB should be enough, then it isn’t working. Calamares logs doesn’t show anything because the process is killed by the OOM process. The only log is a line in the systemd journal stating just that, that the process was killed due to its memory consumption.

Please do not create an issue on the Manjaro GitLab as it is not a packaging issue. Please do not create an upstream issue (yet) as we don’t know what the problem is yet.

No problem for me. You can just try yourself in a VM with 2GiB if you want to debug the problem.

I’ve just done it for you. #announcements threads are not the place to troubleshoot issues.


By default logs are empty. I have to force them with -D parameter to get something. Which level is recommended? I did get something with -D6, but I don’t know if that’s enough

I honestly don’t know as I am not involved in the development of Calamares. Perhaps fiddle around and see. :wink:

Hmm, I’m a notorious low spec user but ‘runs fine’?
What desktop are you using? Try the minimal iso of Xfce or Mate. Best low spec edition I tried were awesome and openbox if you can live without a proper desktop.

Don’t worry. I’m not trying to install anything for my personal use. I was just testing the ISO in a VM. I usually do that with 2GiB of RAM, but this time it didn’t work.

I’m writing this from my Manjaro KDE with 16GiB of RAM :slight_smile:

Ok. It took a little bit, but finally I got something:

Edit: Now that I notice, baloo is running and using memory…

Thanks for posting the log. Calamares was killed by the kernel OOM killer.

Dec 27 23:46:33 manjaro kernel: Out of memory: Killed process 2231 (calamares) total-vm:2589072kB, anon-rss:803852kB, file-rss:0kB, shmem-rss:5136kB, UID:0 pgtables:2360kB oom_score_adj:200
Dec 27 23:46:33 manjaro kernel: oom_reaper: reaped process 2231 (calamares), now anon-rss:0kB, file-rss:0kB, shmem-rss:4624kB
Dec 27 23:46:33 manjaro systemd[1]: user@1000.service: A process of this unit has been killed by the OOM killer.

Then we should probably increase the memory requirement to 4GB. Systems that shipped with 2GB RAM were never meant for 64-bit OSs to begin with.

1 Like

I already said that :smiley:

That’s a pity, because after that it runs fine with 2GiB. At least it boots and I can do basic things. I have not tried to do any real work with 2GiB though.

Did you noticed this?

Dec 27 23:46:33 manjaro kernel: [  pid  ]   uid  tgid total_vm      rss pgtables_bytes swapents oom_score_adj name
Dec 27 23:46:33 manjaro kernel: [   1068]  1000  1068 67187059     1933   188416        0           200 baloo_file
Dec 27 23:46:33 manjaro kernel: [   2231]     0  2231   647268   202247  2416640        0           200 calamares

Baloo is the one that seems to be using a lot of memory. I will try once more disabling Baloo first

Edit: Disabling Baloo didn’t helped :frowning:

Baloo means you are running KDE. You were explicitly asked to try lighter editions (XFCE, Mate).

Just disable Baloo, no legitimate reason to switch desktops, especially since KDE tends to take less resources than XFCE.

@PKraszewski @Locutus
Please, read again the thread

I remember something about Calamares and RAM

A very old issue on github

And that issue is referenced by a newer issue feb. 2022

sudo -E calamares -d &

I thnk the underlying issue could be the lack of swap when booting from ISO combined with the necessary space needed to hold a an squashed filesystem of more than 2gb in-memory. That is somewhat impossible with 2gb ram.

Most installer images are way beyond 2gb today.

I remember the general test recommendation for virtualbox being 2vcpu and 2gb ram.

But then - at that time - we tried to keep the images at max 2gb.

I even think there is a test script which creates a vm with 2gb ram and 10gb disk.

I just did and all it makes me do is stand by what I said cause of what’s been posted in the thread so far.

Then you can see that we are talking about the install environment and that I already tried with baloo disabled (and it didn’t work)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.