Could not find the program 'konsole' error after Manjaro update

Thanks for your reply.
Unfortunately, does that not work for me. I don't have a ~/bin folder, but all the programs I identified so far with this problem (Neovim, Julia, iPython, htop, and others) are both in /bin and in /usr/bin.

I'm on KDE Neon, 5.18. Same issue here. Found out today when trying to launch R and IPython from the application menu.

bump
Same problem on Arch with KDE Plasma. Additionally, since the update I cannot copy files into linked folders. Dolphin prompts me to rename the file, as if it would otherwise overwrite the folder link...

That's a known bug; it's been reported to the KDE bug tracker:
https://bugs.kde.org/show_bug.cgi?id=421213

For now, you can use the cp and mv commands in a terminal to copy or move files into symlinked folders, or drag them into the actual folder (bypassing the symlink).

2 Likes

Blockquote
For now, you can use the cp and mv commands in a terminal to copy or move files into symlinked folders, or drag them into the actual folder (bypassing the symlink).

@tardy , thanks for your suggetion. I am sure it will help those having the same problem as @adkipnis.
However, this is not the main problem reported in this thread.
Any help concerning the "Could not find the program 'konsole'" error will be much appreciated.

1 Like

Bug reported in: https://bugs.kde.org/show_bug.cgi?id=421374, and already fixed in the master branch of kio, to be released with 5.71.

2 Likes

The konsole bug has been squashed since the latest update :smiley:

1 Like

Can't wait to get the update in Manjaro.

The issue is solved in unstable.

1 Like

I ended up here in the process of posting about the "can't find 'konsole'" error (discovered it trying to run terminal Vim), turns out I've been hit with that and the copy/move bug (cp and mv still work in the terminal).

just updated and now i have the exact same issue with tilix. i also have set neovim up this way that when i open files in dolphin they get opened in tilix/ neovim.

now i get the same error- tilix isnt installed.

im on manjaro kde

It is a bug with frameworks. Fixed in 5.70.1

Either wait for the fix to his the stable branch or pull the fixes forward from unstable.

sudo pacman -U https://manjaro.moson.org/unstable/extra/x86_64/kio-5.70.1-1-x86_64.pkg.tar.zst https://manjaro.moson.org/unstable/extra/x86_64/ktexteditor-5.70.1-1-x86_64.pkg.tar.zst 
3 Likes

It gives

error: '/var/cache/pacman/pkg/plasma-framework-5.70.1-1-x86_64.pkg.tar.zst': package missing required signature

Until the moment only in unstable and not listed in testing, the problem also occurs here. Characterized as an of upstream bug
Screenshot_20200521_011653

Remove that from the list. It is no longer in unstable because there is a newer version there now. I think that version of plasma-workspace was already forwarded to stable at this point.

I updated the command above.

If you pull kio and ktexteditor forward as described above it will work in stable.

Problem solved in [Testing Update] 2020-05-21 - Kernels, Toolchain, Mesa, KDE Apps, Cinnamon, Browser.

1 Like

How can I switch to testing branch to get that update on my system?

https://wiki.manjaro.org/index.php?title=Switching_Branches

1 Like

This is fixed with todays kio update in stable branch.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by