Corrupt database, cannot update

I was reading the posts and threads about corrupted databases, but couldnt find a solution, the last thing i tried was:

pamac update
Synchronizing package databases...
Refreshing DEB_Arch_Extra.db...                                                 
Error: DEB_Arch_Extra.db: DEB_Arch_Extra: signature from "MegaLimited <>" is unknown trust
invalid or corrupted database (PGP signature)
Failed to synchronize databases
Cloning bitwig-studio build files...
Generating bitwig-studio information...
Checking bitwig-studio dependencies...
Cloning qt5-styleplugins build files...
Generating qt5-styleplugins information...
Checking qt5-styleplugins dependencies...
Cloning lib32-db build files...
Generating lib32-db information...
Checking lib32-db dependencies...
Cloning tartube build files...
Generating tartube information...
Checking tartube dependencies...
Cloning telegram-desktop-bin build files...
Generating telegram-desktop-bin information...
Checking telegram-desktop-bin dependencies...
Cloning python2 build files...
Generating python2 information...
Checking python2 dependencies...
Cloning teamviewer build files...
Generating teamviewer information...
Checking teamviewer dependencies...
Cloning openssl-1.0 build files...
Generating openssl-1.0 information...
Checking openssl-1.0 dependencies...
Cloning python-dephell-setuptools build files...
Generating python-dephell-setuptools information...
Checking python-dephell-setuptools dependencies...
Cloning ceph build files...
Generating ceph-libs information...
==> ERROR: PKGBUILD does not exist.
Error: Failed to prepare transaction: Failed to generate ceph-libs information

is it that i need to uninstall Mega? or has it nothing to do with it? sorry to be so noob… thanks!!

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

You can search with the term “corrupted database” in the forum and find several solutions.

Had you looked for that, you’d have found that the remedy is to deinstall ceph-libs and run the update again.
You don’t need it.

And, about the corrupted database:

Refreshing DEB_Arch_Extra.db…

That is something external, something that you enabled.
Comment it out … at least for now, so that you can run the update.


thank you so much , ok, i uninstalled ceph-libs,

where do i have to comment out DEB_Arch_Extra.db ?


ok, I guess i have to edit the pacman.conf…

I keep you posted how it goes!

Yes I tried some of them like this one

Invalid or corrupted database - #4 by Yochanan

but without knowing what i was doing it didnt do the trick…

yes, you have put that into /etc/pacman.conf - comment it out (# in front)

1 Like

ok a little update , i still get this:

Warning: elektroid-git: local (2.0.r6.ga62065c-1) is newer than pamac_aur (2.0.beta.r101.ge94eb07-1)
Warning: kvantum-theme-matchama: local (20191118-1) is newer than pamac_aur (r265.8525e05-2)
Resolving dependencies...
Checking inter-conflicts...
Warning: removing 'dbus' from target list because it conflicts with 'dbus-nosystemd'
Error: unresolvable package conflicts detected
Failed to prepare transaction:
conflicting dependencies:
- dbus-nosystemd and dbus-x11 are in conflict
Transaction cancelled.

is it safe to remove dbus-nosystemd or dbus-x11? I m a bit paranoid about that :slight_smile:

I dont know how this got messed up, i was just trying to run an update as usual and didnt install any new packages in between as far as i remember…

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

from the name alone I’m pretty sure that this does not actually belong into your system
because your system does use systemd

1 Like

Before we go any further, please post the content of your pacman.conf. You are using unsupported third-party repos and we need to know what modifications you have made.

cat /etc/pacman.conf

cat /etc/pacman.conf

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
# We cannot check disk space from within a chroot environment

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

###REPO for MEGA###
#SigLevel = Required TrustedOnly
#Server =
###END REPO for MEGA###

also weird: when i search for it dbus-nosystemd does not seem to be installed on my system.

perhaps it depends on how you search

pacman (or pamac?) certainly “thinks” that it is there

… just say yes to replace it?

You probably should install dbus - to replace dbus-x11
the former is the standard repository package - the latter is one from the AUR
… prefer the former to the latter

Using the AUR is not set and forget - it requires maintenance and, ideally, knowing what you are doing :grin:


To verify this sort of information in the future, go to Manjaro Packages: Packages and you’ll see that this package does not exist.

Manjaro users should always read the Stable Update Announcements, at least the first 2 posts. There is a section, where philm lists known issues and/or actions to take.


  • dbus-x11 demoted to AUR


  • ceph, ceph-libs and ceph-mgr dropped to the AUR

Looks like you’ll have some cleanup to do because of the foreign repo that was added to pacman.conf.

1 Like

Thanks stargazer for the infos! Reading the posts now, although not sure what I would need to do to get back to order. when dbus-x11 demotes to AUR and ceph, ,.etc dropped to the AUR, do they compete with the "not foreign " repos and I should delete them? Is there a beginners thread where i can ask questions? It seems people get mad at me cause I have no clue, came from linux mint / debian a while ago but never had this kind of problem. …

Thank you Nachlese, I see, I ll try cleaning up the AUR mess… somehow… I basically install Bitwig-Studio and Mega and Mullvad via AUR as I use it daily , but seems it gives me more trouble that i can handle

I know for a fact that mullvad, which is in the AUR,
which does not require you to add an additional external repository (like Mega),
is not a problem at all.

The external repository is what gave you problems (which are relatively easily solvable - I think - it’s just outdated pgp keys).

1 Like

Thanks Nachlese, so it is Mega, which I commented out in the pacman.conf after that got recommended to me, that gave me the trouble, right? As you recommended I installed dbus (didnt work in pamac but then via the command line sudo pacman -S dbus ) and removed dbus-x11.

I also needed to remove lib32-db to start the system update, now fingers crossed…

The Announcement is the Instruction Manual, if you will, and contains what is new, what has changed, and if action is required. The Announcement’s second post gets updated if something is discovered by users during their update or after their update that is the direct result of the update.

In the Announcement, expand the bullet arrow to the left of the text and it shows what may need to be done. Sometimes there is some wiggle room for the user to take a particular action based on their needs. After reviewing the bullet issues, I would either scroll through the Topic or do a find to get some more details. If you type ctrl-f once, the forum’s software captures the keystroke and you use the forum’s find textbox. If you type it twice, the keystroke is passed to your browser and you use your browser’s find. Most often the course of action is simply to uninstall. In some cases, you might be prompted during the install.

I clipped the expanded text from the Stable Update Announcements for the sake of this conversation:

Just to clarify, software, known as packages (skipping: flatpak, snaps, appimage), are not demoted or dropped to the AUR. The package is removed from the Manjaro supported repositories. It is an important distinction. The package, may or may not be in the AUR.

The AUR is not Manjaro supported. Although, the Manjaro community may help.

You are in the right Category to ask questions. A couple of suggestions:

  1. Browse and search this forum. The forum software is called Discourse.
  2. Checkout the Category, Tutorials.
  3. Checkout the Community maintained wiki.

Since Manjaro is based on Archlinux, the Archlinux wiki can be a helpful resource.

1 Like

super helpful information here , the terminology with packages etc. was not clear to me so this now makes it all more understandable! I will read up and will wrap my head around. If I would have known in the beginning that my problem is caused by packages installed from AUR I would have posted it to the AUR category. now it seems my system is responsive and I am just running the updates , lets see how it goes!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.