Correct way for 1:1 mouse movement / disable mouse acceleration

Hey guys,

I’m using following sh-script in my autostart to disable mouse acceleration and get 1:1 mouse movement (14 is my mouses device ID):

#!/bin/bash

xinput set-prop '14' 'libinput Accel Speed' -1
xinput set-prop '14' 'Coordinate Transformation Matrix' 1 0 0 0 1 0 0 0 0.5

But changing ‘Coordinate Transformation Matrix’ causes problems in some games like European Truck Simulator or The Stanley Parable. In game I cant move my mouse anymore.
On my desktop or in Rust there aren’t any problems.

So where can I change my mouse speed without getting issues?

Ty for help!

I would do it from System Settings > Input Devices > Mouse
But to have advanced settings for it, you have to do this

Read also the alternative there … Move your script elsewhere so it doesn’t interfere.

1 Like

Forum kindly sponsored by Bytemark