Copying Profile From Another Manjaro Installation

Hi all,

I’d had windows and manjaro dual booted and recently deleted windows to free up space on the hard drive. I’d followed instructions here to make sure I was deleting the right partitions. Everything I removed was an NTFS format and should be associated with windows.

Now when I try boot manjaro it gets stuck on the boot screen. There’s an couple errors in the boot sequence. This is despite the EFI partition and manjaro partition remaining intact.

I figured there are 2 options: get the old manjaro fixed and working OR install a fresh manjaro in the free space and restore from backup/copy over files, then delete the old one. I opted for a parallel install as I wanted to encrypt my device now, this also leaves the data on the old installation untouched. I’ve got a fresh install up and running, but for some reason my backup doesn’t work. I’ve copied the contents of my /home folder just fine but I want to get all my configurations in /etc over aswell.

I’ve tried this through 2 methods, through my backup software (Vorta) and by mounting the old manjaro partition and copying files over manually. Each time I do this it runs into permission issues and disallows me from copying over files into /etc.

I had tried

sudo cp -R old_manjaro/etc/* new_manjaro/etc/

but this either wasn’t allowed (I believe due to symlinks in the destination being unchangeable) or it completely bricked the new install.

I’ll also point out that I’ve sucessfully used the backup software and restored my profile using Vorta before. I’m not sure what’s different this time, I don’t recall facing permission issues last time.

The main thing I want to restore is themes/settings/configurations. Can anyone shed any light on which directories hold this and how to get round the permissions issues?

Any help will be thoroughly appreciated!

Also my system:

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=6af44687-1015-45de-bf56-5e167a7dee23 rw quiet
  root=/dev/mapper/luks-8a642ee6-37cd-43f6-b264-c70d8f3b6c30 apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter>
  Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.13.0
  date: 07/22/2021
  ID-1: BAT0 charge: 9.5 Wh (61.7%) condition: 15.4/56.0 Wh (27.5%)
  volts: 11.6 min: 11.4 model: BYD DELL CP6DF99 type: Li-poly serial: <filter>
  status: Discharging
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10)
  microcode: EA cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 62431
  Speed: 1200 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 1200 2: 1200
  3: 1200 4: 1200 5: 1200 6: 1200 7: 1200 8: 1200 9: 1200 10: 1200 11: 1200
  12: 1200
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
  vendor: Hewlett-Packard driver: nouveau v: kernel bus-ID: 01:00.0
  chip-ID: 10de:1f91 class-ID: 0302
  Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting
  alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: N/A v: N/A direct render: N/A
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
  chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: N/A running: no
  Sound Server-3: PulseAudio v: N/A running: no
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
  driver: iwlwifi v: kernel bus-ID: 3b:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp59s0 state: up mac: <filter>
  Local Storage: total: 267.13 GiB used: 61.13 GiB (22.9%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: LITE-ON
  model: CL1-3D256-Q11 NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 22301111 temp: 28.9 C
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Blade
  size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A
  serial: <filter> rev: 1.00
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-1: / raw-size: 123.2 GiB size: 120.71 GiB (97.98%)
  used: 47.37 GiB (39.2%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-8a642ee6-37cd-43f6-b264-c70d8f3b6c30
  ID-2: /boot/efi raw-size: 680 MiB size: 676 MiB (99.41%)
  used: 87.9 MiB (13.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: nouveau temp: 37.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
uptime: /usr/lib/ version `GLIBC_2.35' not found (required by /usr/lib/
uptime: /usr/lib/ version `GLIBC_2.34' not found (required by /usr/lib/
  Processes: 0 Uptime: N/A wakeups: 9111 Memory: 7.41 GiB
  used: 4.04 GiB (54.5%) Init: systemd v: N/A tool: systemctl Compilers:
  gcc: N/A Packages: pacman: 1225 lib: 333 flatpak: 0 Shell: Unknown Shell
  running-in: pty pts/2 (vt 1) inxi: 3.3.07

are you now in live usb or in your install?

On a new install - you shouldn’t copy over /etc.

You only need your settings from your old home folder.

You may find ideas using this topic as a starting point

1 Like