Controlling the screen brightness on Surface Pro 3

Hi.

I've been stuck with this issue for a long time. I have absolutely no way of controlling the screen brightness. I tried installing different software from AUR to no avail.

I'm trying to control the screen brightness using the F1 & F2 keys. I know it is done through i3 config but I don't think my distro has the necessary software/driver installed to control the screen brightness. I'm not 100% sure about it but that's what my assumption is.

The secondary issue is that, while on Chrome, F1 launches support.google.com, which would make decreasing screen brightness not possible while browsing the internet. I don't know if that's an i3 config file thing or a Chrome thing.

Do you have on your keyboard some kind of fn-key? I can't see any in the image you posted.
Usually when you have brightness, volume and so on on your F-keys there is another key named Fn which switches between the normal F-key functions and the other functions. And if you're lucky you can switch the default-mode of those keys in the BIOS.

I do.

Do you happen to know how I can control my screen brightness?

Use the Fn key along with Function keys and play play around with to see which does what.

Just tried. No decrease in brightness.

You could try following:

  1. Install brightnessctl
sudo pacman -S brightnessctl
  1. Insert or change the following lines in your i3-config (~/.config/i3/config)
#XF86MonBrightness
bindsym XF86MonBrightnessDown exec brightnessctl set 5%-
bindsym XF86MonBrightnessUp exec brightnessctl set +5%

And yes, the + and - signs must be placed this way for brightnessctl.

  1. Reload the configuration file.
    The default is to press Mod1+Shift+c.

I've done the changes but how do I increase/decrease the brightness now?

Minor correction: The path is ~/.i3/config

Good, if ~/.i3/config still works for you. I had to change to ~/.config/i3/config after an i3-update a few months ago because the old paths wasn't sourced any more. Maybe they did give you back the option to use this path after this.
But back to topic: I forgot to tell you step 4. Try pressing F1 and F2 with and without pressing the Fn-key. I would guess that it has to be with Fn, otherwise you wouldn't get the behaviour of Chrome by just pressing F1 as you described above.

If it still doesn't work you should look into your BIOS if you can find something.

The last thing I can think of is, that you need some kind of kernel-option. I guess acpi_backlight=vendor. Others can be found here.

How do I look into my BIOS for this?

That depends on your device. The manufacturers are handling this so different that I couldn't possibly know it. On my thinkpad it's first the RETURN-key directly after starting the laptop and then the F1-key to enter the BIOS-setup. On the devices I had before it was F1, F2, Esc or F8.
In most cases you get for a short while a hint how to break the startup-process after pressing the power-key. I don't know how it's handled just on your device. Maybe someone else here can answer this.
The same applies the options inside your BIOS-setup. You just have to look around if you find something relating to Fn keys, multimedia keys, special keys or similar.

But I shouldn't need to tinker with BIOS. There has to be a way I can access the drivers to control the screen brightness.

Did you test if the keys worked like I told you before?

Forum kindly sponsored by