Context menu items not opening on desktop

Hi everyone,
i make my First steps within the new Manjaro with Gnome 40. And it feels realy good. But i figured out a little Problem. If i do a right Click on the Desktop a litte menu is opening. But if i choose settings or Display settings nothing will happen. Is this a normal behavior or do i something wrong??

Welcome to the forum! :wave:

I’ve edited your topic title to be more descriptive. What you’re referring to is the context menu (right-click) that’s provided by the Desktop Icons NG (DING) GNOME Shell Extension. You should have gnome-shell-extension-desktop-icons-ng 23-1 installed.

Open Add/Remove Software, click on Updates at the top and see if any updates are available. If so, perform the update, reboot and see if you can reproduce the issue.

Thanks for your support on this issue.
I’ve done a Re-install of this Package you mentioned. After this checked for Updates, but there were no available. I performed a reboot but these steps changed nothing. The issue is still existing.

Maybe it is helpful to point out that i installed Manjaro fresh yesterday. As i mentioned before i am walking my first steps on this.

Is it possible that i have just to activate one of those Extensions from the Extensions Menu?

I activated Desktop Icons NG (DING) for testing.
The interesting thing is the new Options from the "right Klick " menu are working as expected. but the ones which exist on both options (activated and non Activated) don’t.

Let’s be clear: Which context menus are not working? What is the exact name of it /them?

all 3 which are in this menu.
These are:

  • Change Background…
  • Display Settings
  • Settings

None of these cause any effekt if i click on them.

Run the following command…

journalctl -f -o cat /usr/bin/gnome-shell

…then reproduce the issue. Copy and paste the output here, highlight it and click the Preformatted text </> button to format it properly.

Purposely misspelling words is not appropriate for the support forum environment. Please review How to Post.

journalctl -f -o cat /usr/bin/gnome-shell                                                                                                                                                         
Window manager warning: Overwriting existing binding of keysym ff52 with keysym ff52 (keycode 6f).
Window manager warning: Overwriting existing binding of keysym 73 with keysym 73 (keycode 27).
Window manager warning: Overwriting existing binding of keysym 61 with keysym 61 (keycode 26).
Window manager warning: Overwriting existing binding of keysym ff54 with keysym ff54 (keycode 74).
ATK Bridge is disabled but a11y has already been enabled.
GNOME Shell started at Wed Oct 27 2021 16:50:59 GMT+0200 (Mitteleuropäische Sommerzeit)
Registering session with GDM
Connection to xwayland lost
updates_checker.vala:71: check updates
updates_checker.vala:101: 0 updates found
Settings panel for desktop file gnome-background-panel.desktop could not be loaded!
Settings panel for desktop file gnome-display-panel.desktop could not be loaded!
Settings panel for desktop file gnome-control-center.desktop could not be loaded!

I solved the issue.
The problem was that a Package called gnome-control-center was missing.
The installation of this package solved this issue.

Thank you so much for supporting a newbie. :see_no_evil:

Y’know, I had a tickle in the back of my mind to ask about that, but that’s installed by default. :man_facepalming:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.