Context menu in Dolphin - Mount ISO and disk images is gone

Up until a few weeks ago I could use rightclick on an img file to mount it in dolphin. Then it just disappeared one day.
Other context menus are still there like “open as root” f.ex.

Asking here before turning to KDE forums.

I found this: [SOLVED] KDE - Dolphin: missing mount iso / Applications & Desktop Environments / Arch Linux Forums
dolphin-plugins are installed:
extra/dolphin-plugins 23.08.2-2 (kde-applications kdesdk) [installed]

And this: KDE dolphin context menu // plugins do not work anymore? - Plasma - EndeavourOS
That led me to this: 475659 – Selection for ISO integration is missing in the Dolphin menu after the update

Maybe the bug is not fixed yet and therefore not fixed here either? I’m trying to understand these things. :smiley:
I’d rather not implement the patch myself, or should I? Might break stuff when things are being updated?

Its not in any updated release yet … so its not in any of the packages either.

Which you can also verify by the timestamps and content of the package changes:

And again if you like in comparison to manjaro branches:

1 Like

If you’re really desperate and can’t wait then you could just add the application/x-cd-image mime type it’s currently looking for. Probably won’t break anything and easy to revert if it does.

System Settings → Applications → File Associations, add that type with *.iso file pattern and remove *.iso file pattern from application/vnd.efi.iso.

1 Like

So THAT is what has been changed that KDE needed to update. I understood through some of the discussions on the threads that it is something with the classifications of the img files and looked at the commits.

I’m ok, it’s a bit annoying to loop and mount every time in cli (I do that a lot and I have become lazy), but I made a script in the meantime, I can wait. :slight_smile:
But thank you for the clarification!

I also suspect the reason I got no response on KDE forums is because this is on them to fix, but it’s still not done. :wink:
I see the relative to Mr. IKEA is hard at work at KDE. xD

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.