Constant crackling noise from microphone, couldn't solve despite many similar topics

My microphone has constant crackling noise. This problem seems to be very common, but none of the solutions worked for me. My pulseaudio automatically starts after I pulseaudio -k even though autospawn was marked as no. Therefore I couldn’t close my pulseaudio and thought maybe settings didn’t apply, but restarting the pc didn’t work and I assume that restarts pulseaudio. Issue doesn’t persist in Windows 10.

And some system information

System:    Host: eren-gl638rc Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GL63 8RC v: REV:1.0 serial: <superuser required> 
           Mobo: Micro-Star model: MS-16P6 v: REV:1.0 serial: <superuser required> UEFI: American Megatrends v: E16P6IMS.109 
           date: 05/22/2019 
Battery:   ID-1: BAT1 charge: 40.4 Wh (98.8%) condition: 40.9/43.2 Wh (94.6%) 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP cache: L2: 9 MiB 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nvidia v: 465.31 
           Device-3: Acer HD Webcam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.2 
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
           Sound Server-3: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
           IF: wlo1 state: down mac: 96:57:91:21:b2:a5 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 30:9c:23:8e:f3:a2 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb 
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: see --recommends 
Drives:    Local Storage: total: 1.48 TiB used: 35.05 GiB (2.3%) 
           ID-1: /dev/sda vendor: Kingston model: RBUSNS8180S3128GJ size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB 
           ID-3: /dev/sdc type: USB vendor: Samsung model: Portable SSD T5 size: 465.76 GiB 
Partition: ID-1: / size: 24.44 GiB used: 13.5 GiB (55.2%) fs: ext4 dev: /dev/sdc4 
           ID-2: /boot/efi size: 511 MiB used: 1.5 MiB (0.3%) fs: vfat dev: /dev/sdc3 
           ID-3: /home size: 84.59 GiB used: 7.49 GiB (8.9%) fs: ext4 dev: /dev/sdc5 
Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 292 Uptime: 29m Memory: 15.48 GiB used: 3.24 GiB (20.9%) Shell: Zsh inxi: 3.3.04 
1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
        driver: <module-alsa-card.c>
        state: RUNNING
        suspend cause: (none)
        priority: 9039
        volume: front-left: 40720 /  62% / -12,40 dB,   front-right: 40720 /  62% / -12,40 dB
                balance 0,00
        base volume: 65536 / 100% / 0,00 dB
        volume steps: 65537
        muted: no
        current latency: 100,85 ms
        max request: 18 KiB
        max rewind: 18 KiB
        monitor source: 0
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
        used by: 1
        linked by: 1
        fixed latency: 100,00 ms
        card: 0 <alsa_card.pci-0000_00_1f.3>
        module: 6
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
       = "ALC892 Analog"
       = "ALC892 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xa4310000 irq 134"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
       = "8086"
       = "Intel Corporation"
       = "a348"
       = "Cannon Lake PCH cAVS"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "19200"
                device.buffering.fragment_size = "4800"
                device.access_mode = "mmap"
       = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
                                device.icon_name = "audio-headphones"
        active port: <analog-output-headphones>

Some solutions I tried:
Static noise in microphone recording
Microphone crackling with Realtek ALC892
[solved] Crackling sound
Constant static sound coming from input device, even when microphone is muted

That looks quite old: Have you tried upgrading your firmware yet? If not, try that before trying anything else.


@Fabby I wish I could. Pretty sure this is the latest version.

The Windows driver could contain a workaround for a hardware problem, so that doesn’t mean anything, so have you tried another microphone already? (E.G. The cheap headset that came free with your phone)


I removed my headset’s mic jack and laptop’s internal microphone sounds fine

1 Like

Sounds like a hardware problem. What’s the exact brand/model of the mic?

HyperX Cloud Stinger. I found some posts about crackling noise in Microsoft/Arch/Manjaro/Ubuntu forums but I am not sure if it is just a coincidence, it is a pretty popular headset for 50$- budgets. Also I checked with my Android phone and microphone is fine there as well. Should I check with another distro, would that be helpful?


If they tell you: “We don’t support Linux”, never buy that brand again and tell all your friends not to buy it any more either…


PulseAudio configuration /etc/pulse/client.conf is set to autospawn=no by default in Manjaro
PulseAudio server is controlled on Manjaro by systemd socket and service rather than autospawning the deamon is userspace

PulseAudio should be restarted using the command:

systemctl --user restart pulseaudio.service

using -k or --kill option direct to PulseAudio will break pulseaudio.service
PulseAudio will restart when killed, but in an altered state without some modules, and sink outputs and source inputs can also be suspended and inaudible

Audio may be impaired by sound server Pipewire running concurrent with PulseAudio

           Sound Server-2: PulseAudio v: 14.2 running: yes 
           Sound Server-3: PipeWire v: 0.3.30 running: yes 

Pipewire cannot run properly unless additional packages are installed and PulseAudio is removed but it might impair operation of PulseAudio

I suggest you stop Pipewire server

systemctl --user stop pipewire.socket
systemctl --user stop pipewire.service
1 Like

I tried but the problem persists.

Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 

Maybe I can try the same solutions from Arch Linux wiki with my newfound knowledge.

Thread will go inactive soon I think so I will post the final situation and mark it as solved, I can edit it if there is a change.

I am using a virtual machine and microphone passthrough to solve the problem temporarily. There are probably less wasteful solutions but I use the virtual machine anyways so there isn’t really unnecessary resources.

@Fabby I contacted their support and I don’t think they have a problem with Linux support. They asked me a few questions and lead me to RMA department. It was really fast until then but I have been waiting for an answer from RMA for 12 days.

Thanks for help everyone :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.