Conservation mode on Legion 5?

whatever that might mean to you :wink:

It obviously does not mean anything to me.

If I understand your topic correctly - after reading thoroughly several times - you want to prolong the battery life as long as possible.

That is likely true - please do realise that computer systems of today are built for Windows OS.

Linux is not like Windows and therefore some hardware work badly or not at all using a GNU/Linux system. This is especially true for WiFi networking, touch pad and advanced battery management.

This is not a flaw of Linux but a flaw of hardware vendors.

The best advise you can get is to consider compatibility with Linux when shopping a computer system.


I get where you’re coming from and I agree that it’s a flaw from the hardware vendors, to even add up I like Linux much more than windows.
Now to clarify for you I have dual boot windows and manjaro, I use Windows for gaming and Linux for my work and day-to-day use, on windows I have the Lenovo vantage application which has conservation mode which puts a cap on the battery at 60% now my problem is that if I want the conservation mode I have to activate it from windows meaning I have to boot to windows to turn the option on and then boot again to Linux to complete my usage, I could do that but it’s not handy or efficient for my time. So I was checking if there is a solution for that or a workaround, I did find some workaround for what I’m looking for but I can’t seem to get it working.
Here you could find almost the same device I’m using hence the same commands and options apply
but I can’t seem to get it working, whenever I type the command

# echo 1 >/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode

it just goes to the following command so I assume it’s on but then when I try it I find it’s not, I proceed to try

sudo echo 1 >/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode

but it gives me permission denied so I really can’t get it working.
Just to add up I don’t seem to have a problem with Linux working on my device there is always a solution you just have to find it.
Lenovo devices with compatibility
Mine is the “Legion 5”
thanks for taking the time to help me.

I have no idea what conservation_mode is but since it is about battery I am guessing it has something to do with prolonging overall battery life span by not deep discharge nor charge to full capacity.

If you get permission error it is likely the firmware which doesn’t allow the change or the device does not exist

ls /sys/bus/platform/drivers/ideapad_acpi

Find your battery name - below examples is obtained on a ThinkPad T550 - don’t expect your system to be identical

[nix@panther ~]$ ls /sys/class/power_supply
[nix@panther ~]$ ls /sys/class/power_supply/BAT0
alarm                           charge_stop_threshold  hwmon2        serial_number  voltage_min_design
capacity                        cycle_count            manufacturer  status         voltage_now
capacity_level                  device                 model_name    subsystem
charge_control_end_threshold    energy_full            power         technology
charge_control_start_threshold  energy_full_design     power_now     type
charge_start_threshold          energy_now             present       uevent
[nix@panther ~]$ cat /sys/class/power_supply/BAT0/charge_start_threshold
ls /sys/bus/platform/drivers/ideapad_acpi

what should I be looking for here exactly?

Here is the result though

VPC2004:00  bind  module  uevent  unbind

Could you also provide me with a link to a power management tool that would work fine for my device?

just for further understanding. Is it right that you want the charging stopped at 60% ?

tlp - but you need to take into consideration that charge cap only works with select devices as it depends on the firmware and availability of modules for the device.

Use a custom script to notify when to unplug the charger and when to plug it

That’s the conservation mode through lenovo vantage.
But for me I wouldn’t mind if I can get to choose where to limit it.

I tried tlp, and found that it has a battery charger limit but it broke my brightness controls since it works only for ideapad or ThinkPad something like that

take your time and read,check and try the settings of tlp. it’s too complex to give a simple answer.
you have to research especially as newcommer to linux
the link below might give you a start

1 Like

I have tried something that solved my issue and applied the conservation mode
So the problem was when you type the command

sudo echo 1 >/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode

will give you a permission denied I googled and found the solution to be using either the tee or the

sudo bash -c 'echo 1 >/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode'

If you want to disable it just replace the 1 with a 0

1 Like

I don’t think that tlp would work fine for me, gave me a couple of issues when I first started it.
What about the laptop-mode-tools or is it not as good as tlp?

in fact, i’m also very critical to tlp. i disabled it complete because it troubles more as it solves for my case but that might be a complete difference to others who like it. it depends on the hardware and i have to admit that my acer-laptop is a piece of crap. next time i will reasearch a lot more before buying some crap of hardware.

This is what I use to apply “conservation” mode on my Legion 5 Pro laptop –


Thank you so much <3

@owburp sorry for the bother but how do I install it?
I’ve cloned it with

git clone

but when I run anything else it doesn’t execute

No bother at all. I’ve gotten a lot of help from this forum and I’m just doing my part in return.

Install lenopow by going to Pamac and, assuming you have enabled AUR Support in it, do a search; it should appear and allow you to install it.
But note that lenopow is not an application, it’s a script that is used within terminal. So open up your terminal and enter
lenopow -h
that displays the help screen and you can see what can be input.


Worked like a charm thanks <3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.