Connection issues HP Wi-Fi rtw88_8821ce

Hi everyone,
new to this forum, so bare with me if i am missing something.
I just got a new HP laptop today with a Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter and installed the current image from the manjaro website.
Whenever I connect to my WiFi, it will work for a couple of seconds, then traffic just stops. While the wifi connection is still up without showing any errors, I cant even ping my router.

I read a lot about problems with the 8821ce and also tried installing the AUR driver with no success.
I have tried both Kernel 5.15 LTS and 5.17, no dice.
Another weird behaviour is, that if I connect the laptop to a different SSID on the same router (my router provides a separated wifi for guests), it works without any problems.

Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A
modules: rtw88_8821ce,8821ce pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp1s0 state: down mac:
Device-2: AVM GmbH FRITZ WLAN N v2 [RT5572/rt2870.bin] type: USB
driver: rt2800usb bus-ID: 3-2:5 chip-ID: 057c:8501 class-ID: 0000
IF: wlp3s0f4u2 state: up mac:
IP v4: type: dynamic noprefixroute scope: global

Dont bother about the Device-2, I just used that adapter to write this posting.
Also please let me know if you need any additional info.

No success in installing it or making it working?
You have to do this before installing the driver

Also, you can disable mac address randomization and IPv6.

1 Like

Hey bogdan,
thanks for the quick reply.
I ran some tests in the last few hours, including the steps you suggested, none of them worked though.
The simple solution was, to set the channel of my WiFi to “Automatic”.

So it wasn’t a driver issue at all, ugh…took me a while to remember i set a custom channel there.
Thanks for your help though!